summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-04-22 16:19:36 +0000
committerMichał Górny <mgorny@gentoo.org>2013-04-22 16:19:36 +0000
commit76838097baacf585b638a4fc6d0cb512666b040d (patch)
treec77be5934681f009e51f57ec05c16783df330c22 /dev-python
parentadd longdescription to metadata (bug #465524) (diff)
downloadgentoo-2-76838097baacf585b638a4fc6d0cb512666b040d.tar.gz
gentoo-2-76838097baacf585b638a4fc6d0cb512666b040d.tar.bz2
gentoo-2-76838097baacf585b638a4fc6d0cb512666b040d.zip
Fix alternating install design by the egg_info command. Fixes bug #466302.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wxpython/ChangeLog7
-rw-r--r--dev-python/wxpython/files/wxpython-2.8.12.1-disable-egging-mode.patch34
-rw-r--r--dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild4
-rw-r--r--dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild4
4 files changed, 46 insertions, 3 deletions
diff --git a/dev-python/wxpython/ChangeLog b/dev-python/wxpython/ChangeLog
index 74504a397721..8587e8962f04 100644
--- a/dev-python/wxpython/ChangeLog
+++ b/dev-python/wxpython/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/wxpython
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.179 2013/04/10 03:44:28 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/ChangeLog,v 1.180 2013/04/22 16:19:35 mgorny Exp $
+
+ 22 Apr 2013; Michał Górny <mgorny@gentoo.org>
+ +files/wxpython-2.8.12.1-disable-egging-mode.patch,
+ wxpython-2.8.12.1-r1.ebuild, wxpython-2.9.4.1-r1.ebuild:
+ Fix alternating install design by the egg_info command. Fixes bug #466302.
10 Apr 2013; Ryan Hill <dirtyepic@gentoo.org> wxpython-2.8.12.1-r1.ebuild,
-wxpython-2.9.4.1.ebuild, wxpython-2.9.4.1-r1.ebuild:
diff --git a/dev-python/wxpython/files/wxpython-2.8.12.1-disable-egging-mode.patch b/dev-python/wxpython/files/wxpython-2.8.12.1-disable-egging-mode.patch
new file mode 100644
index 000000000000..1497a2c70761
--- /dev/null
+++ b/dev-python/wxpython/files/wxpython-2.8.12.1-disable-egging-mode.patch
@@ -0,0 +1,34 @@
+From c4072ed7bc923039e544319f52d0761b7a4600a4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Mon, 22 Apr 2013 18:02:37 +0200
+Subject: [PATCH] Trigger 'EGGing' mode only by 'bdist_egg' and not 'egg_info'.
+
+We use the 'egg_info' command to explicitly enforce temporary EGG file
+location outside the source tree on Gentoo. As a result, our build
+command activates the 'EGGing' mode and wxPython is not installed
+properly.
+
+I believe that the 'EGGing' mode should be activated only by an explicit
+call to 'bdist_egg' command where the expected files are actually
+created. The 'egg_info' command is a more broad one and is often used
+implicitly, e.g. by the 'install' command.
+---
+ config.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/config.py b/config.py
+index 4fbd83f..b45707d 100644
+--- a/config.py
++++ b/config.py
+@@ -23,7 +23,7 @@
+ import sys, os, glob, fnmatch, tempfile
+ import subprocess
+
+-EGGing = 'bdist_egg' in sys.argv or 'egg_info' in sys.argv
++EGGing = 'bdist_egg' in sys.argv
+ if not EGGing:
+ from distutils.core import setup, Extension
+ else:
+--
+1.8.1.5
+
diff --git a/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild b/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild
index d1e74a6dd1ed..0a186d8d4283 100644
--- a/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild,v 1.5 2013/04/10 03:44:28 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.8.12.1-r1.ebuild,v 1.6 2013/04/22 16:19:35 mgorny Exp $
EAPI=5
@@ -66,6 +66,8 @@ python_prepare_all() {
"${FILESDIR}"/${PN}-2.8.12-drop-editra.patch
"${FILESDIR}"/${PN}-2.8.12-drop-categories.patch
"${FILESDIR}"/${PN}-2.8-no-preservatives-added.patch
+ # fix handling egg_info command
+ "${FILESDIR}"/${PN}-2.8.12.1-disable-egging-mode.patch
)
distutils-r1_python_prepare_all
diff --git a/dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild b/dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild
index 2eeae6c1e541..2977b7b5f473 100644
--- a/dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild
+++ b/dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild,v 1.4 2013/04/10 03:44:28 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wxpython/wxpython-2.9.4.1-r1.ebuild,v 1.5 2013/04/22 16:19:35 mgorny Exp $
EAPI=5
@@ -61,6 +61,8 @@ python_prepare_all() {
# drop editra - we have it as a separate package now
"${FILESDIR}"/${PN}-2.8.11-drop-editra.patch
"${FILESDIR}"/${PN}-2.8-no-preservatives-added.patch
+ # fix handling egg_info command
+ "${FILESDIR}"/${PN}-2.8.12.1-disable-egging-mode.patch
)
distutils-r1_python_prepare_all