summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2015-01-09 16:02:26 +0000
committerJohann Schmitz <ercpe@gentoo.org>2015-01-09 16:02:26 +0000
commit77fdda793163b4a1b662fb6c428128dfa289fb78 (patch)
treeed736d2c8c4692b61eedaf71a80d6db00e32dcde /dev-python
parentRun eautoreconf at the appropriate moment, as per Jeroen Roovers in bug #5361... (diff)
downloadgentoo-2-77fdda793163b4a1b662fb6c428128dfa289fb78.tar.gz
gentoo-2-77fdda793163b4a1b662fb6c428128dfa289fb78.tar.bz2
gentoo-2-77fdda793163b4a1b662fb6c428128dfa289fb78.zip
Version bump of django-two-factor-auth
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-two-factor-auth/ChangeLog10
-rw-r--r--dev-python/django-two-factor-auth/django-two-factor-auth-1.1.0.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-python/django-two-factor-auth/ChangeLog b/dev-python/django-two-factor-auth/ChangeLog
index 547174d55401..be0416442e21 100644
--- a/dev-python/django-two-factor-auth/ChangeLog
+++ b/dev-python/django-two-factor-auth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/django-two-factor-auth
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-two-factor-auth/ChangeLog,v 1.1 2014/12/28 09:41:35 ercpe Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-two-factor-auth/ChangeLog,v 1.2 2015/01/09 16:02:26 ercpe Exp $
+
+*django-two-factor-auth-1.1.0 (09 Jan 2015)
+
+ 09 Jan 2015; Johann Schmitz <ercpe@gentoo.org>
+ +django-two-factor-auth-1.1.0.ebuild:
+ Version bump of django-two-factor-auth
*django-two-factor-auth-1.0.0 (28 Dec 2014)
diff --git a/dev-python/django-two-factor-auth/django-two-factor-auth-1.1.0.ebuild b/dev-python/django-two-factor-auth/django-two-factor-auth-1.1.0.ebuild
new file mode 100644
index 000000000000..5fe6fd06d79d
--- /dev/null
+++ b/dev-python/django-two-factor-auth/django-two-factor-auth-1.1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-two-factor-auth/django-two-factor-auth-1.1.0.ebuild,v 1.1 2015/01/09 16:02:26 ercpe Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="User-friendly Two-Factor Authentication for Django"
+HOMEPAGE="https://github.com/Bouke/django-two-factor-auth"
+SRC_URI="https://github.com/Bouke/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test yubikey"
+
+CDEPEND=">=dev-python/django-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/django-otp-0.2.0[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/twilio[${PYTHON_USEDEP}]
+ yubikey? ( dev-python/django-otp-yubikey[${PYTHON_USEDEP}] )
+ "
+
+RDEPEND="${CDEPEND}"
+DEPEND="test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ )"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i "/'qrcode/s/^/#/" setup.py || die
+}
+
+python_test() {
+ emake test || die
+}