summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-07-01 06:44:51 +0000
committerTim Harder <radhermit@gentoo.org>2014-07-01 06:44:51 +0000
commit8d46afb970e7aede4ced991f354277b4593e432c (patch)
treee0e21294414b984d289e14555d05d98778f73775 /dev-python
parentBump per bug #513228. (diff)
downloadgentoo-2-8d46afb970e7aede4ced991f354277b4593e432c.tar.gz
gentoo-2-8d46afb970e7aede4ced991f354277b4593e432c.tar.bz2
gentoo-2-8d46afb970e7aede4ced991f354277b4593e432c.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygit2/ChangeLog7
-rw-r--r--dev-python/pygit2/pygit2-0.21.0.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-python/pygit2/ChangeLog b/dev-python/pygit2/ChangeLog
index efd188d046ec..91875533e783 100644
--- a/dev-python/pygit2/ChangeLog
+++ b/dev-python/pygit2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pygit2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/ChangeLog,v 1.25 2014/04/03 01:21:02 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/ChangeLog,v 1.26 2014/07/01 06:44:51 radhermit Exp $
+
+*pygit2-0.21.0 (01 Jul 2014)
+
+ 01 Jul 2014; Tim Harder <radhermit@gentoo.org> +pygit2-0.21.0.ebuild:
+ Version bump.
*pygit2-0.20.3 (03 Apr 2014)
diff --git a/dev-python/pygit2/pygit2-0.21.0.ebuild b/dev-python/pygit2/pygit2-0.21.0.ebuild
new file mode 100644
index 000000000000..f3cfaf9fb110
--- /dev/null
+++ b/dev-python/pygit2/pygit2-0.21.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygit2/pygit2-0.21.0.ebuild,v 1.1 2014/07/01 06:44:51 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2"
+SRC_URI="https://github.com/libgit2/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-libs/libgit2-$(get_version_component_range 1-2)*
+ dev-python/cffi[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}