summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-25 08:30:42 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-25 08:30:42 +0000
commit91a3f5ca0ac2597494dfe85b0a392d1de006517e (patch)
treea4106ac93773acead7247849cea59cb07ba8c377 /dev-python
parentVersion bump. (diff)
downloadgentoo-2-91a3f5ca0ac2597494dfe85b0a392d1de006517e.tar.gz
gentoo-2-91a3f5ca0ac2597494dfe85b0a392d1de006517e.tar.bz2
gentoo-2-91a3f5ca0ac2597494dfe85b0a392d1de006517e.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/urwid/ChangeLog7
-rw-r--r--dev-python/urwid/urwid-1.1.2.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-python/urwid/ChangeLog b/dev-python/urwid/ChangeLog
index 8e2b6666c73f..893105f885d4 100644
--- a/dev-python/urwid/ChangeLog
+++ b/dev-python/urwid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/urwid
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.63 2014/01/05 02:08:38 yac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.64 2014/01/25 08:30:42 radhermit Exp $
+
+*urwid-1.1.2 (25 Jan 2014)
+
+ 25 Jan 2014; Tim Harder <radhermit@gentoo.org> +urwid-1.1.2.ebuild:
+ Version bump.
05 Jan 2014; Jan Matejka <yac@gentoo.org> urwid-1.0.2.ebuild:
<1.1 doesn't work with python > 3.2
diff --git a/dev-python/urwid/urwid-1.1.2.ebuild b/dev-python/urwid/urwid-1.1.2.ebuild
new file mode 100644
index 000000000000..18b659ffcf88
--- /dev/null
+++ b/dev-python/urwid/urwid-1.1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-1.1.2.ebuild,v 1.1 2014/01/25 08:30:42 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python"
+HOMEPAGE="http://urwid.org/ http://pypi.python.org/pypi/urwid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/twisted-core )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.1.0-sphinx.patch )
+
+python_compile_all() {
+ if use doc ; then
+ if [[ ${EPYTHON} == python3* ]] ; then
+ 2to3 -nw --no-diffs docs/conf.py || die
+ fi
+ cd docs
+ sphinx-build . _build/html || die
+ fi
+}
+
+python_compile() {
+ if [[ ${EPYTHON} == python2* ]] ; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}