summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-09 12:56:06 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-09 12:56:06 +0000
commit98ec74e4add15de1a1a5133ca08e29c132387d3d (patch)
tree8d317cc993b36540abde32714d42e300c52aad79 /dev-python
parentstable ppc, bug #428872 (diff)
downloadgentoo-2-98ec74e4add15de1a1a5133ca08e29c132387d3d.tar.gz
gentoo-2-98ec74e4add15de1a1a5133ca08e29c132387d3d.tar.bz2
gentoo-2-98ec74e4add15de1a1a5133ca08e29c132387d3d.zip
Bump
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/testify/ChangeLog7
-rw-r--r--dev-python/testify/testify-0.2.8.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-python/testify/ChangeLog b/dev-python/testify/ChangeLog
index 8acfc7a7efe1..838a0437a1d2 100644
--- a/dev-python/testify/ChangeLog
+++ b/dev-python/testify/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/testify
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.3 2012/07/30 07:06:26 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/ChangeLog,v 1.4 2012/10/09 12:56:06 patrick Exp $
+
+*testify-0.2.8 (09 Oct 2012)
+
+ 09 Oct 2012; Patrick Lauer <patrick@gentoo.org> +testify-0.2.8.ebuild:
+ Bump
*testify-0.2.7 (30 Jul 2012)
diff --git a/dev-python/testify/testify-0.2.8.ebuild b/dev-python/testify/testify-0.2.8.ebuild
new file mode 100644
index 000000000000..35cca4c29ccf
--- /dev/null
+++ b/dev-python/testify/testify-0.2.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testify/testify-0.2.8.ebuild,v 1.1 2012/10/09 12:56:06 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+# TODO: verify 2.5
+RESTRICT_PYTHON_ABIS="2.5 3.* 2.7-pypy-*"
+
+inherit eutils distutils vcs-snapshot
+
+DESCRIPTION="A more pythonic replacement for the unittest module and nose"
+HOMEPAGE="https://github.com/Yelp/testify http://pypi.python.org/pypi/testify/"
+SRC_URI="https://github.com/Yelp/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml
+ dev-python/sqlalchemy
+ www-servers/tornado
+ || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )"
+DEPEND="dev-python/setuptools
+ test? ( ${RDEPEND} )"
+
+#DOCS="README.txt"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/${PN}-0.2.6-tests.patch
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib/" "$(PYTHON)" bin/${PN} test
+ }
+ python_execute_function testing
+}