summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-01-10 06:17:48 +0000
committerTim Harder <radhermit@gentoo.org>2015-01-10 06:17:48 +0000
commita62c8b4dae3601b0bb5df53b8a121156f7f0d2aa (patch)
treec0ddf14a80da4a03285e2e73f8bb2dd65778d611 /dev-python
parentFix bug 531932 (diff)
downloadgentoo-2-a62c8b4dae3601b0bb5df53b8a121156f7f0d2aa.tar.gz
gentoo-2-a62c8b4dae3601b0bb5df53b8a121156f7f0d2aa.tar.bz2
gentoo-2-a62c8b4dae3601b0bb5df53b8a121156f7f0d2aa.zip
Add python3_3 and python3_4 to PYTHON_COMPAT and update test functionality.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto/ChangeLog5
-rw-r--r--dev-python/boto/boto-2.35.1.ebuild10
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-python/boto/ChangeLog b/dev-python/boto/ChangeLog
index c49717b02895..bd342a7adb52 100644
--- a/dev-python/boto/ChangeLog
+++ b/dev-python/boto/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/boto
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.101 2015/01/10 06:00:55 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/ChangeLog,v 1.102 2015/01/10 06:17:48 radhermit Exp $
+
+ 10 Jan 2015; Tim Harder <radhermit@gentoo.org> boto-2.35.1.ebuild:
+ Add python3_3 and python3_4 to PYTHON_COMPAT and update test functionality.
*boto-2.35.1 (10 Jan 2015)
diff --git a/dev-python/boto/boto-2.35.1.ebuild b/dev-python/boto/boto-2.35.1.ebuild
index 61c32ee4e392..6cbaf565bb06 100644
--- a/dev-python/boto/boto-2.35.1.ebuild
+++ b/dev-python/boto/boto-2.35.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.35.1.ebuild,v 1.1 2015/01/10 06:00:55 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/boto/boto-2.35.1.ebuild,v 1.2 2015/01/10 06:17:48 radhermit Exp $
EAPI="5"
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
@@ -14,12 +14,14 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
# requires Amazon Web Services keys to pass some tests
RESTRICT="test"
python_test() {
- esetup.py test
+ "${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
}