summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2007-01-11 22:11:57 +0000
committerMarien Zwart <marienz@gentoo.org>2007-01-11 22:11:57 +0000
commita9a039c4807ec037c4f7efda31cbd088e37a76b8 (patch)
treeb80ca8e02ff14bedae717f9821c83c62ae495edf /dev-python
parentUpdate old install-sh in tarball to enable installation on fbsd. Bug #159238 (diff)
downloadgentoo-2-a9a039c4807ec037c4f7efda31cbd088e37a76b8.tar.gz
gentoo-2-a9a039c4807ec037c4f7efda31cbd088e37a76b8.tar.bz2
gentoo-2-a9a039c4807ec037c4f7efda31cbd088e37a76b8.zip
Version bump, drop revision patched to work with python 2.5 (use the new bump instead).
(Portage version: 2.1.2_rc4-r8)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted/ChangeLog16
-rw-r--r--dev-python/twisted/files/digest-twisted-2.2.06
-rw-r--r--dev-python/twisted/files/digest-twisted-2.5.03
-rw-r--r--dev-python/twisted/twisted-2.5.0.ebuild108
4 files changed, 128 insertions, 5 deletions
diff --git a/dev-python/twisted/ChangeLog b/dev-python/twisted/ChangeLog
index d63986907e66..437c882eab6d 100644
--- a/dev-python/twisted/ChangeLog
+++ b/dev-python/twisted/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for dev-python/twisted
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.83 2006/10/20 20:36:34 kloeri Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/ChangeLog,v 1.84 2007/01/11 22:11:57 marienz Exp $
+
+*twisted-2.5.0 (11 Jan 2007)
+
+ 11 Jan 2007; Marien Zwart <marienz@gentoo.org>
+ -files/twisted-2.4.0-python-2.5-compat.patch,
+ -files/twisted-2.4.0-remove-newjelly.patch,
+ -files/twisted-2.4.0-trial-attempted-fix.patch,
+ -files/twisted-2.4.0-trial-python-2.5-compat.patch,
+ -files/twisted-2.4.0-unjellyable.patch, -twisted-2.4.0-r1.ebuild,
+ +twisted-2.5.0.ebuild:
+ Version bump, drop revision patched to work with python 2.5 (use the new
+ bump instead).
20 Oct 2006; Bryan Østergaard <kloeri@gentoo.org> twisted-2.4.0.ebuild:
Stable on Alpha.
diff --git a/dev-python/twisted/files/digest-twisted-2.2.0 b/dev-python/twisted/files/digest-twisted-2.2.0
index 12337b77cc2b..7f14c3fcf099 100644
--- a/dev-python/twisted/files/digest-twisted-2.2.0
+++ b/dev-python/twisted/files/digest-twisted-2.2.0
@@ -1,3 +1,3 @@
-MD5 4a9305e69cdcf01a594c4fe1ea1efc05 Twisted-2.2.0.tar.bz2 1285316
-RMD160 c11353da93878721c8549a0594363b9d8ee38e12 Twisted-2.2.0.tar.bz2 1285316
-SHA256 537ec738c23ced2ec4a9b7f7124c2cd9bded1308331442ced0f3de7cd7562387 Twisted-2.2.0.tar.bz2 1285316
+MD5 f7864c76bde3dddd905bf8720495fe9d Twisted-2.2.0.tar.bz2 266240
+RMD160 b4c0ebbf6f599b2b28f95a36b367cde44594bd21 Twisted-2.2.0.tar.bz2 266240
+SHA256 d25e8cdc2ba22037230bc7572a6ee172cd1be339ac92ba57b63c4f5b520c7ba1 Twisted-2.2.0.tar.bz2 266240
diff --git a/dev-python/twisted/files/digest-twisted-2.5.0 b/dev-python/twisted/files/digest-twisted-2.5.0
new file mode 100644
index 000000000000..e1611a214a7e
--- /dev/null
+++ b/dev-python/twisted/files/digest-twisted-2.5.0
@@ -0,0 +1,3 @@
+MD5 cf8d8d73c3b58b79c6a16b5fc23d5b61 TwistedCore-2.5.0.tar.bz2 2049409
+RMD160 b2abe479286ef903054b182c6d408c8f3e5aad86 TwistedCore-2.5.0.tar.bz2 2049409
+SHA256 3404a92012734d527a7b2029ce6f588bbc02b27904760819b2ce86f81bcddaab TwistedCore-2.5.0.tar.bz2 2049409
diff --git a/dev-python/twisted/twisted-2.5.0.ebuild b/dev-python/twisted/twisted-2.5.0.ebuild
new file mode 100644
index 000000000000..ddc7a84fdd1c
--- /dev/null
+++ b/dev-python/twisted/twisted-2.5.0.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/twisted/twisted-2.5.0.ebuild,v 1.1 2007/01/11 22:11:57 marienz Exp $
+
+inherit eutils distutils versionator
+
+MY_P=TwistedCore-${PV}
+
+DESCRIPTION="An asynchronous networking framework written in Python"
+HOMEPAGE="http://www.twistedmatrix.com/"
+SRC_URI="http://tmrc.mit.edu/mirror/twisted/Twisted/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk serial crypt"
+
+DEPEND=">=dev-lang/python-2.3
+ >=net-zope/zopeinterface-3.0.1
+ serial? ( dev-python/pyserial )
+ crypt? ( >=dev-python/pyopenssl-0.5.1 )
+ gtk? ( >=dev-python/pygtk-1.99 )
+ !dev-python/twisted-docs"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CREDITS INSTALL NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Give a load-sensitive test a better chance of succeeding.
+ epatch "${FILESDIR}/${PN}-2.1.0-echo-less.patch"
+
+ # Pass valid arguments to "head" in the zsh completion function.
+ epatch "${FILESDIR}/${PN}-2.1.0-zsh-head.patch"
+}
+
+src_install() {
+ distutils_src_install
+
+ # get rid of this to prevent collision-protect from killing us. it
+ # is regenerated in pkg_postinst.
+ rm "${D}/usr/$(get_libdir)"/python*/site-packages/twisted/plugins/dropin.cache
+
+ # weird pattern to avoid installing the index.xhtml page
+ doman doc/man/*.?
+ insinto /usr/share/doc/${PF}
+ doins -r $(find doc -mindepth 1 -maxdepth 1 -not -name man)
+
+ # workaround for a possible portage bug
+ mkdir -p "${D}/etc/conf.d/"
+ newconfd "${FILESDIR}/twistd.conf" twistd
+ newinitd "${FILESDIR}/twistd.init" twistd
+
+ # zsh completion
+ insinto /usr/share/zsh/site-functions/
+ doins twisted/python/_twisted_zsh_stub
+}
+
+update_plugin_cache() {
+ python_version
+ local tpath="${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/twisted"
+ # we have to remove the cache or removed plugins won't be removed
+ # from the cache (http://twistedmatrix.com/bugs/issue926)
+ [[ -e "${tpath}/plugins/dropin.cache" ]] && rm -f "${tpath}/plugins/dropin.cache"
+ if [[ -e "${tpath}/plugin.py" ]]; then
+ # twisted is still installed, update.
+ # we have to use getPlugIns here for <=twisted-2.0.1 compatibility
+ einfo "Regenerating plugin cache"
+ python -c "from twisted.plugin import IPlugin, getPlugIns;list(getPlugIns(IPlugin))"
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ update_plugin_cache
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ update_plugin_cache
+}
+
+src_test() {
+ python_version
+
+ if has_version ">=dev-lang/python-2.3"; then
+ "${python}" setup.py install --root="${T}/tests" --no-compile || die
+ else
+ "${python}" setup.py install --root="${T}/tests" || die
+ fi
+
+ cd "${T}/tests/usr/$(get_libdir)/python${PYVER}/site-packages/" || die
+
+ # prevent it from pulling in plugins from already installed
+ # twisted packages
+ rm twisted/plugins/__init__.py || die
+
+ # an empty file doesn't work because the tests check for
+ # docstrings in all packages
+ echo "'''plugins stub'''" > twisted/plugins/__init__.py || die
+
+ PYTHONPATH=. "${T}"/tests/usr/bin/trial twisted || die "trial failed"
+ cd "${S}"
+ rm -rf "${T}/tests"
+}