summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-28 10:19:25 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-28 10:19:25 +0000
commitc5216cb760a29506081cf3f1dd5d11de827f530f (patch)
treeac719a268a52d59540429736139592433ffaf343 /dev-python
parentRemove USE=bash-completion, install the completion file unconditionally follo... (diff)
downloadgentoo-2-c5216cb760a29506081cf3f1dd5d11de827f530f.tar.gz
gentoo-2-c5216cb760a29506081cf3f1dd5d11de827f530f.tar.bz2
gentoo-2-c5216cb760a29506081cf3f1dd5d11de827f530f.zip
bump; add doc build
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/testtools/ChangeLog7
-rw-r--r--dev-python/testtools/testtools-0.9.36.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/testtools/ChangeLog b/dev-python/testtools/ChangeLog
index 5338042b1cca..ba386cff98f7 100644
--- a/dev-python/testtools/ChangeLog
+++ b/dev-python/testtools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/testtools
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/ChangeLog,v 1.93 2014/07/19 19:48:10 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/ChangeLog,v 1.94 2014/08/28 10:19:25 idella4 Exp $
+
+*testtools-0.9.36 (28 Aug 2014)
+
+ 28 Aug 2014; Ian Delaney <idella4@gentoo.org> +testtools-0.9.36.ebuild:
+ bump; add doc build
19 Jul 2014; Tobias Klausmann <klausman@gentoo.org> testtools-0.9.34.ebuild:
Stable on alpha, bug #506620
diff --git a/dev-python/testtools/testtools-0.9.36.ebuild b/dev-python/testtools/testtools-0.9.36.ebuild
new file mode 100644
index 000000000000..52ffd2ab4fc0
--- /dev/null
+++ b/dev-python/testtools/testtools-0.9.36.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/testtools/testtools-0.9.36.ebuild,v 1.1 2014/08/28 10:19:25 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1 versionator
+
+#SERIES="$(get_version_component_range 1-2)"
+SERIES="trunk"
+
+DESCRIPTION="Extensions to the Python unittest library"
+HOMEPAGE="https://launchpad.net/testtools http://pypi.python.org/pypi/testtools"
+SRC_URI="http://launchpad.net/${PN}/${SERIES}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+RDEPEND="dev-python/mimeparse[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( $(python_gen_cond_dep 'dev-python/twisted-core[${PYTHON_USEDEP}]' python2_7) )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # https://bugs.launchpad.net/testtools/+bug/1191725
+ # These tests pass run from the source, a gentooism
+ if ! python_is_python3; then
+ sed -e s':test_deferredruntest:#&:g' \
+ -e s':test_spinner:#&:g' \
+ -i ${PN}/tests/__init__.py || die
+ fi
+ # Bug 509510 re python-2.7.6
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}