summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-11-25 17:16:46 +0000
committerMike Gilbert <floppym@gentoo.org>2014-11-25 17:16:46 +0000
commitc7ac1035f3f13210f00a75d4c0ce5c034db0bf00 (patch)
tree475f7ffb0e0912f071ef317f466040b77e954b82 /dev-python
parentVersion bump (bug #529082). Added python-3.4 support (bug #530308) (diff)
downloadgentoo-2-c7ac1035f3f13210f00a75d4c0ce5c034db0bf00.tar.gz
gentoo-2-c7ac1035f3f13210f00a75d4c0ce5c034db0bf00.tar.bz2
gentoo-2-c7ac1035f3f13210f00a75d4c0ce5c034db0bf00.zip
Remove upper bound on dev-python/paramiko dep, bug 528154.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fabric/ChangeLog8
-rw-r--r--dev-python/fabric/fabric-1.10.0-r1.ebuild (renamed from dev-python/fabric/fabric-1.9.1.ebuild)22
-rw-r--r--dev-python/fabric/fabric-1.9.0.ebuild56
3 files changed, 23 insertions, 63 deletions
diff --git a/dev-python/fabric/ChangeLog b/dev-python/fabric/ChangeLog
index 7da2b19a0e13..fe8fc0ef0c0d 100644
--- a/dev-python/fabric/ChangeLog
+++ b/dev-python/fabric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/fabric
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/ChangeLog,v 1.52 2014/11/07 04:29:53 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/ChangeLog,v 1.53 2014/11/25 17:16:46 floppym Exp $
+
+*fabric-1.10.0-r1 (25 Nov 2014)
+
+ 25 Nov 2014; Mike Gilbert <floppym@gentoo.org> +fabric-1.10.0-r1.ebuild,
+ -fabric-1.9.0.ebuild, -fabric-1.9.1.ebuild:
+ Remove upper bound on dev-python/paramiko dep, bug 528154.
07 Nov 2014; Ian Delaney <idella4@gentoo.org> fabric-1.10.0.ebuild:
ditto to fabric-1.10.0.ebuild wrt Bug #528154
diff --git a/dev-python/fabric/fabric-1.9.1.ebuild b/dev-python/fabric/fabric-1.10.0-r1.ebuild
index e6d5d0a1f43a..9212bc745c07 100644
--- a/dev-python/fabric/fabric-1.9.1.ebuild
+++ b/dev-python/fabric/fabric-1.10.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/fabric-1.9.1.ebuild,v 1.3 2014/11/06 03:27:54 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/fabric-1.10.0-r1.ebuild,v 1.1 2014/11/25 17:16:46 floppym Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -21,20 +21,30 @@ IUSE="doc test"
RDEPEND="
>=dev-python/paramiko-1.10[${PYTHON_USEDEP}]
- <dev-python/paramiko-1.13[${PYTHON_USEDEP}]
- "
+"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/python-docs-2.7.6-r1:2.7
dev-python/alabaster[${PYTHON_USEDEP}] )
- test? ( <dev-python/fudge-1.0[${PYTHON_USEDEP}] )"
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ <dev-python/fudge-1.0[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}] )"
S="${WORKDIR}/${MY_P}"
python_prepare_all() {
- sed -e "s/, 'sphinx.ext.intersphinx'//" -i sites/docs/conf.py || die
+ # Re-set intersphinx_mapping for doc build
+ if use doc; then
+ local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
+ local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
+ local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
+ local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
+ sed -e "s|'http://docs.python.org/2.6', None|'${PYTHON_DOC}', '${PYTHON_DOC_INVENTORY}'|" \
+ -e "s| 'www'| #'www'|" \
+ -i sites/docs/conf.py || die
+ fi
distutils-r1_python_prepare_all
-
}
python_compile_all() {
diff --git a/dev-python/fabric/fabric-1.9.0.ebuild b/dev-python/fabric/fabric-1.9.0.ebuild
deleted file mode 100644
index 151abda419b3..000000000000
--- a/dev-python/fabric/fabric-1.9.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/fabric-1.9.0.ebuild,v 1.4 2014/08/10 21:10:24 slyfox Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN="Fabric"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A simple pythonic tool for remote execution and deployment"
-HOMEPAGE="http://fabfile.org http://pypi.python.org/pypi/Fabric"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-# since 'paramiko>=1.10' is what we have in portage, paramiko can be set unversioned
-RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/alabaster[${PYTHON_USEDEP}] )
- test? ( <dev-python/fudge-1.0[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- sed -e "s/, 'sphinx.ext.intersphinx'//" -i sites/docs/conf.py || die
- distutils-r1_python_prepare_all
-
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build -b html -c sites/docs/ sites/docs/ sites/docs/html || die
- fi
-}
-
-src_test() {
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- nosetests tests || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( sites/docs/html/. )
- distutils-r1_python_install_all
-}