summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2014-12-13 11:34:11 +0000
committerPatrice Clement <monsieurp@gentoo.org>2014-12-13 11:34:11 +0000
commitce12540861ee2c91c1673ed4cd9a36349dc6a913 (patch)
tree8ff47bdd63fcfec211931eadc7a70a53a67aa27f /dev-python
parentStop RDEPENDing on obsolete font (#282754), drop old (diff)
downloadgentoo-2-ce12540861ee2c91c1673ed4cd9a36349dc6a913.tar.gz
gentoo-2-ce12540861ee2c91c1673ed4cd9a36349dc6a913.tar.bz2
gentoo-2-ce12540861ee2c91c1673ed4cd9a36349dc6a913.zip
Converted to distutils-r1, added required IUSE test as well as test phase, rm old. Crosstested and approved by idella4. See #316509.
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/buzhug/ChangeLog12
-rw-r--r--dev-python/buzhug/buzhug-1.8-r1.ebuild (renamed from dev-python/buzhug/buzhug-1.8.ebuild)22
2 files changed, 21 insertions, 13 deletions
diff --git a/dev-python/buzhug/ChangeLog b/dev-python/buzhug/ChangeLog
index deb3ace5f869..8617bc4d8c59 100644
--- a/dev-python/buzhug/ChangeLog
+++ b/dev-python/buzhug/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/buzhug
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/buzhug/ChangeLog,v 1.7 2010/09/27 17:44:40 arfrever Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/buzhug/ChangeLog,v 1.8 2014/12/13 11:34:11 monsieurp Exp $
+
+*buzhug-1.8-r1 (13 Dec 2014)
+
+ 13 Dec 2014; Patrice Clement <monsieurp@gentoo.org> +buzhug-1.8-r1.ebuild,
+ -buzhug-1.8.ebuild:
+ Converted to distutils-r1, added required IUSE test as well as test phase, rm
+ old. Crosstested and approved by idella4. See #316509.
*buzhug-1.8 (27 Sep 2010)
@@ -64,4 +71,3 @@
03 Jul 2006; Tiziano Müller <gentoo@dev-zero.ch> ChangeLog:
New ebuild for bug 138267
-
diff --git a/dev-python/buzhug/buzhug-1.8.ebuild b/dev-python/buzhug/buzhug-1.8-r1.ebuild
index 6b2cbafa712f..db67428702f3 100644
--- a/dev-python/buzhug/buzhug-1.8.ebuild
+++ b/dev-python/buzhug/buzhug-1.8-r1.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/buzhug/buzhug-1.8.ebuild,v 1.1 2010/09/27 17:44:40 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/buzhug/buzhug-1.8-r1.ebuild,v 1.1 2014/12/13 11:34:11 monsieurp Exp $
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
+EAPI="5"
-inherit distutils
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
DESCRIPTION="Fast, pure-Python database engine, using a syntax that Python programmers should find very intuitive"
HOMEPAGE="http://buzhug.sourceforge.net/ http://pypi.python.org/pypi/buzhug"
@@ -17,7 +15,11 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
DEPEND="app-arch/unzip"
-RDEPEND=""
+RDEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}