summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-01-21 05:46:14 +0000
committerIan Delaney <idella4@gentoo.org>2013-01-21 05:46:14 +0000
commitcef2f582f79417aa1db252cdeb79b157bd74e446 (patch)
tree7fce12d874565d104739a934143df5b736030275 /dev-python
parentAdd support for USE=static-softmmu and USE=static-user. Break out build rules... (diff)
downloadgentoo-2-cef2f582f79417aa1db252cdeb79b157bd74e446.tar.gz
gentoo-2-cef2f582f79417aa1db252cdeb79b157bd74e446.tar.bz2
gentoo-2-cef2f582f79417aa1db252cdeb79b157bd74e446.zip
PYTHONPATH set in test phase to 1.2.9
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-pipeline/ChangeLog8
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.2.6.ebuild6
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.2.9.ebuild8
3 files changed, 14 insertions, 8 deletions
diff --git a/dev-python/django-pipeline/ChangeLog b/dev-python/django-pipeline/ChangeLog
index 036e3194d016..7d23d46ae570 100644
--- a/dev-python/django-pipeline/ChangeLog
+++ b/dev-python/django-pipeline/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/django-pipeline
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/ChangeLog,v 1.8 2012/12/04 15:39:33 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/ChangeLog,v 1.9 2013/01/21 05:46:14 idella4 Exp $
+
+ 21 Jan 2013; Ian Delaney <idella4@gentoo.org> django-pipeline-1.2.6.ebuild,
+ django-pipeline-1.2.9.ebuild:
+ PYTHONPATH set in test phase to 1.2.9
04 Dec 2012; <ago@gentoo.org> django-pipeline-1.2.9.ebuild:
Stable for x86, wrt bug #443422
diff --git a/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild b/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild
index 0f3bfbbba10f..7d164dc72ca6 100644
--- a/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild
+++ b/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild,v 1.1 2012/05/20 12:15:46 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild,v 1.2 2013/01/21 05:46:14 idella4 Exp $
EAPI=4
PYTHON_DEPEND="2"
@@ -12,7 +12,7 @@ inherit distutils
DESCRIPTION="An asset packaging library for Django"
HOMEPAGE="http://pypi.python.org/pypi/django-pipeline/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE="doc"
LICENSE="MIT"
diff --git a/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild b/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild
index e599eef599d6..0d67653fe6d5 100644
--- a/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild
+++ b/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild,v 1.5 2012/12/04 15:39:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.2.9.ebuild,v 1.6 2013/01/21 05:46:14 idella4 Exp $
EAPI=4
PYTHON_DEPEND="2:2.6"
@@ -12,7 +12,8 @@ inherit distutils
DESCRIPTION="An asset packaging library for Django"
HOMEPAGE="http://pypi.python.org/pypi/django-pipeline/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="amd64 x86"
+
+KEYWORDS="amd64 ~x86"
IUSE="doc"
LICENSE="MIT"
@@ -35,6 +36,7 @@ src_test() {
testing() {
local exit_status=0 test
pushd build-${PYTHON_ABI}/lib/tests/tests/ > /dev/null || die
+ PYTHONPATH=.
for test in [a-z]*.py
do
if ! "$(PYTHON)" ${test}; then