summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-13 16:23:35 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-13 16:23:35 +0000
commitd3dfc6411ae324200e1ecf8a5bcbacc7a5e9a7a4 (patch)
treea0717c2abcc8907363b6e532ceb32b93f965d9ab /dev-python
parentRemove old version. (diff)
downloadgentoo-2-d3dfc6411ae324200e1ecf8a5bcbacc7a5e9a7a4.tar.gz
gentoo-2-d3dfc6411ae324200e1ecf8a5bcbacc7a5e9a7a4.tar.bz2
gentoo-2-d3dfc6411ae324200e1ecf8a5bcbacc7a5e9a7a4.zip
Revbump. Fixes bug 188405 and bug 274017
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt/ChangeLog10
-rw-r--r--dev-python/PyQt/PyQt-3.18-r1.ebuild60
-rw-r--r--dev-python/PyQt/files/python_2.5_build_fix.patch11
3 files changed, 80 insertions, 1 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index 3bc8357702ed..f1ca3d86e2f0 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/PyQt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.116 2009/06/09 20:12:15 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.117 2009/06/13 16:23:35 hwoarang Exp $
+
+*PyQt-3.18-r1 (13 Jun 2009)
+
+ 13 Jun 2009; Markos Chandras <hwoarang@gentoo.org>
+ +files/python_2.5_build_fix.patch, +PyQt-3.18-r1.ebuild:
+ Revbump. Fixes pre-stripped files ( bug 188405 thanks to Victor Ostorga ).
+ Fixes python-2.5
+ compatibility ( bug 274017 ).
09 Jun 2009; Markos Chandras <hwoarang@gentoo.org> PyQt-3.18.ebuild:
Silently drop qt4 use dependency from qscintilla
diff --git a/dev-python/PyQt/PyQt-3.18-r1.ebuild b/dev-python/PyQt/PyQt-3.18-r1.ebuild
new file mode 100644
index 000000000000..e17c89699f3f
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.18-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.18-r1.ebuild,v 1.1 2009/06/13 16:23:35 hwoarang Exp $
+
+EAPI="2"
+inherit distutils
+
+MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A set of Python bindings for Qt3"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/PyQt3/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+
+RDEPEND="x11-libs/qt:3
+ >=dev-python/sip-4.8
+ >=x11-libs/qscintilla-2.4[python]"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_prepare() {
+ sed -i -e "s: check_license():# check_license():" "${S}"/configure.py
+ epatch "${FILESDIR}"/python_2.5_build_fix.patch
+}
+
+src_configure() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d $(python_get_sitedir) \
+ -b /usr/bin \
+ -v /usr/share/sip \
+ -n /usr/include \
+ -o /usr/$(get_libdir) \
+ -w -y qt-mt
+ -u"
+ use debug && myconf="${myconf} -u"
+
+ "${python}" configure.py ${myconf} || die 'configure failed'
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ python_need_rebuild
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README THANKS
+ use doc && dohtml doc/PyQt.html
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples3/* "${D}"/usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/PyQt/files/python_2.5_build_fix.patch b/dev-python/PyQt/files/python_2.5_build_fix.patch
new file mode 100644
index 000000000000..f52f56510e1a
--- /dev/null
+++ b/dev-python/PyQt/files/python_2.5_build_fix.patch
@@ -0,0 +1,11 @@
+--- PyQt-x11-gpl-3.18/sip/qt/qobject.sip 2009-06-05 11:58:25.000000000 +0300
++++ PyQt-x11-gpl-3.18.1-snapshot-20090610/sip/qt/qobject.sip 2009-06-11 05:30:14.000000000 +0300
+@@ -1649,7 +1649,7 @@
+ // universal slot a child of the transmitter. This doesn't work as
+ // expected because QWidget destroys its children before emitting the
+ // destroyed signal.)
+- if (tx && PyObject_TypeCheck(tx, (PyTypeObject *)sipClass_QObject))
++ if (tx && PyObject_TypeCheck((PyObject *)tx, (PyTypeObject *)sipClass_QObject))
+ qtx = reinterpret_cast<QObject *>(conn.sc_transmitter);
+
+ return new UniversalSlot(qtx, &conn, member);