summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-11 16:05:33 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-11 16:05:33 +0000
commite5b36c19b55ceb9153bbd29d7e5fc6d9376135e6 (patch)
treec09d36749382941ad83fbd0ebe4217a34cadf27b /dev-python
parentFixed building against mono-2.10 with patches from Arch (bug #362623) (diff)
downloadgentoo-2-e5b36c19b55ceb9153bbd29d7e5fc6d9376135e6.tar.gz
gentoo-2-e5b36c19b55ceb9153bbd29d7e5fc6d9376135e6.tar.bz2
gentoo-2-e5b36c19b55ceb9153bbd29d7e5fc6d9376135e6.zip
Fix tests with Python 3.2 (bug #321841).
(Portage version: 2.2.0_alpha29_p12/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/decorator/ChangeLog6
-rw-r--r--dev-python/decorator/decorator-3.3.0.ebuild9
-rw-r--r--dev-python/decorator/files/decorator-3.3.0-python-3.2.patch22
3 files changed, 34 insertions, 3 deletions
diff --git a/dev-python/decorator/ChangeLog b/dev-python/decorator/ChangeLog
index fa93555bceb1..464c3c555858 100644
--- a/dev-python/decorator/ChangeLog
+++ b/dev-python/decorator/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/decorator
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/ChangeLog,v 1.36 2011/02/27 21:47:41 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/ChangeLog,v 1.37 2011/04/11 16:05:33 arfrever Exp $
+
+ 11 Apr 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ decorator-3.3.0.ebuild, +files/decorator-3.3.0-python-3.2.patch:
+ Fix tests with Python 3.2 (bug #321841).
27 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-decorator-3.2.0.ebuild, -decorator-3.2.1.ebuild:
diff --git a/dev-python/decorator/decorator-3.3.0.ebuild b/dev-python/decorator/decorator-3.3.0.ebuild
index fe2b3fff8f14..7b950251c237 100644
--- a/dev-python/decorator/decorator-3.3.0.ebuild
+++ b/dev-python/decorator/decorator-3.3.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/decorator-3.3.0.ebuild,v 1.7 2011/04/11 15:27:43 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/decorator-3.3.0.ebuild,v 1.8 2011/04/11 16:05:33 arfrever Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
PYTHON_TESTS_RESTRICTED_ABIS="2.4 2.5"
-inherit distutils
+inherit distutils eutils
DESCRIPTION="Simplifies the usage of decorators for the average programmer"
HOMEPAGE="http://pypi.python.org/pypi/decorator http://code.google.com/p/micheles/"
@@ -23,6 +23,11 @@ RDEPEND=""
DOCS="README.txt"
PYTHON_MODNAME="decorator.py"
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${P}-python-3.2.patch"
+}
+
src_test() {
testing() {
if [[ "${PYTHON_ABI}" == 3.* ]]; then
diff --git a/dev-python/decorator/files/decorator-3.3.0-python-3.2.patch b/dev-python/decorator/files/decorator-3.3.0-python-3.2.patch
new file mode 100644
index 000000000000..6e9eb851bea5
--- /dev/null
+++ b/dev-python/decorator/files/decorator-3.3.0-python-3.2.patch
@@ -0,0 +1,22 @@
+http://code.google.com/p/micheles/source/detail?r=929b7bda62b98489f2d9952b1ef6046ce27c1704
+
+--- documentation3.py
++++ documentation3.py
+@@ -660,7 +660,7 @@
+
+ .. code-block:: python
+
+- >>> f()
++ >>> f() # doctest: +ELLIPSIS
+ Traceback (most recent call last):
+ ...
+ File "<string>", line 2, in f
+@@ -668,7 +668,7 @@
+ return f(*args, **kw)
+ File "<doctest __main__[51]>", line 3, in f
+ 1/0
+- ZeroDivisionError: int division or modulo by zero
++ ZeroDivisionError: ...
+
+ You see here the inner call to the decorator ``trace``, which calls
+ ``f(*args, **kw)``, and a reference to ``File "<string>", line 2, in f``.