summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-03-17 08:36:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-03-17 08:36:07 +0000
commite9432b2223c12e5b6073d2ac2c2e5d94b3a924e0 (patch)
tree9c480ad1a978a6eac7042c5f21a04621f2d431e3 /dev-python
parentversion bump, update subslot, bug #540080 (diff)
downloadgentoo-2-e9432b2223c12e5b6073d2ac2c2e5d94b3a924e0.tar.gz
gentoo-2-e9432b2223c12e5b6073d2ac2c2e5d94b3a924e0.tar.bz2
gentoo-2-e9432b2223c12e5b6073d2ac2c2e5d94b3a924e0.zip
Bump
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cffi/ChangeLog7
-rw-r--r--dev-python/cffi/cffi-0.9.2.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/cffi/ChangeLog b/dev-python/cffi/ChangeLog
index 68c50cbd3717..9070bde6632e 100644
--- a/dev-python/cffi/ChangeLog
+++ b/dev-python/cffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cffi
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.48 2015/03/11 07:08:43 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/ChangeLog,v 1.49 2015/03/17 08:36:07 patrick Exp $
+
+*cffi-0.9.2 (17 Mar 2015)
+
+ 17 Mar 2015; Patrick Lauer <patrick@gentoo.org> +cffi-0.9.2.ebuild:
+ Bump
*cffi-0.9.1 (11 Mar 2015)
diff --git a/dev-python/cffi/cffi-0.9.2.ebuild b/dev-python/cffi/cffi-0.9.2.ebuild
new file mode 100644
index 000000000000..0dc836ef29cf
--- /dev/null
+++ b/dev-python/cffi/cffi-0.9.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cffi/cffi-0.9.2.ebuild,v 1.1 2015/03/17 08:36:07 patrick Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Foreign Function Interface for Python calling C code"
+HOMEPAGE="http://cffi.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="doc"
+
+RDEPEND="virtual/libffi
+ dev-python/pycparser[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test -x -v --ignore testing/test_zintegration.py c/ testing/ || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use doc && dohtml -r doc/build/
+}