summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-03-28 10:51:19 +0000
committerMichał Górny <mgorny@gentoo.org>2013-03-28 10:51:19 +0000
commite9bd7da37caa6adfaa0de5feee6676d15316f521 (patch)
tree1611a8ec10c630606bb723ef6b3b16edf3a26e58 /dev-python
parentBump. Changed to using a phar with all the bundled deps (which is only used b... (diff)
downloadgentoo-2-e9bd7da37caa6adfaa0de5feee6676d15316f521.tar.gz
gentoo-2-e9bd7da37caa6adfaa0de5feee6676d15316f521.tar.bz2
gentoo-2-e9bd7da37caa6adfaa0de5feee6676d15316f521.zip
Fix the -r1 backport by syncing up to the fresh ebuild. Fixes bug #463572.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/webob/ChangeLog5
-rw-r--r--dev-python/webob/webob-1.0.8-r1.ebuild46
2 files changed, 28 insertions, 23 deletions
diff --git a/dev-python/webob/ChangeLog b/dev-python/webob/ChangeLog
index 61682efdb093..0abcb5b8f325 100644
--- a/dev-python/webob/ChangeLog
+++ b/dev-python/webob/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/webob
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.68 2013/03/27 14:09:05 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/ChangeLog,v 1.69 2013/03/28 10:51:19 mgorny Exp $
+
+ 28 Mar 2013; Michał Górny <mgorny@gentoo.org> webob-1.0.8-r1.ebuild:
+ Fix the -r1 backport by syncing up to the fresh ebuild. Fixes bug #463572.
27 Mar 2013; Agostino Sarubbo <ago@gentoo.org> webob-1.2.3.ebuild:
Stable for arm, wrt bug #456614
diff --git a/dev-python/webob/webob-1.0.8-r1.ebuild b/dev-python/webob/webob-1.0.8-r1.ebuild
index f068e892da0c..8e46422492e0 100644
--- a/dev-python/webob/webob-1.0.8-r1.ebuild
+++ b/dev-python/webob/webob-1.0.8-r1.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.0.8-r1.ebuild,v 1.1 2013/03/25 15:28:35 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webob/webob-1.0.8-r1.ebuild,v 1.2 2013/03/28 10:51:19 mgorny Exp $
-EAPI="5"
-PYTHON_COMPAT=( python2_{5,6,7} )
+EAPI=5
-inherit distutils-r1 eutils
+PYTHON_COMPAT=( python{2_6,2_7} )
-MY_PN="WebOb"
-MY_P="${MY_PN}-${PV}"
+inherit distutils-r1
+
+MY_PN=WebOb
+MY_P=${MY_PN}-${PV}
DESCRIPTION="WSGI request and response object"
HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
@@ -17,31 +18,32 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
+IUSE="doc" # test"
DEPEND="app-arch/unzip
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+# test? ( dev-python/nose[${PYTHON_USEDEP}]
+# dev-python/webtest[${PYTHON_USEDEP}] )"
RDEPEND=""
-S="${WORKDIR}/${MY_P}"
+# Almost impossible to solve circ-dep with dev-python/webtest.
+# (due to different PYTHON_COMPAT)
+RESTRICT=test
-src_compile() {
- distutils-r1_python_compile
+S=${WORKDIR}/${MY_P}
+python_compile_all() {
if use doc; then
- einfo "Generation of documentation"
- "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
+ "${PYTHON}" setup.py build_sphinx || die
fi
}
-src_install() {
- distutils-r1_python_install
+python_test() {
+ nosetests -w tests || die "Tests fail with ${EPYTHON}"
+}
- if use doc; then
- pushd build/sphinx/html > /dev/null
- insinto /usr/share/doc/${PF}/html
- doins -r [a-z]* _static || die "Installation of documentation failed"
- popd > /dev/null
- fi
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
}