summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-14 10:52:16 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-14 10:52:16 +0000
commitefac5fef11bb31e8eb4f3b5bdd6218b83c5bcb7a (patch)
tree3577cd47e79db3435afdd8bd9c1a92f9b29d9bef /dev-python
parentBump crypto-conduit to 0.5.5 (diff)
downloadgentoo-2-efac5fef11bb31e8eb4f3b5bdd6218b83c5bcb7a.tar.gz
gentoo-2-efac5fef11bb31e8eb4f3b5bdd6218b83c5bcb7a.tar.bz2
gentoo-2-efac5fef11bb31e8eb4f3b5bdd6218b83c5bcb7a.zip
bump; add new dep, update test phase, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/logbook/ChangeLog8
-rw-r--r--dev-python/logbook/logbook-0.8.1.ebuild (renamed from dev-python/logbook/logbook-0.5.0.ebuild)20
2 files changed, 20 insertions, 8 deletions
diff --git a/dev-python/logbook/ChangeLog b/dev-python/logbook/ChangeLog
index 92e6c8daf4e8..1fb4fae6d17e 100644
--- a/dev-python/logbook/ChangeLog
+++ b/dev-python/logbook/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/logbook
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.20 2014/12/05 10:17:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.21 2014/12/14 10:52:16 idella4 Exp $
+
+*logbook-0.8.1 (14 Dec 2014)
+
+ 14 Dec 2014; Ian Delaney <idella4@gentoo.org> +logbook-0.8.1.ebuild,
+ -logbook-0.5.0.ebuild:
+ bump; add new dep, update test phase, rm old
05 Dec 2014; Agostino Sarubbo <ago@gentoo.org> logbook-0.7.0.ebuild:
Stable for x86, wrt bug #530532
diff --git a/dev-python/logbook/logbook-0.5.0.ebuild b/dev-python/logbook/logbook-0.8.1.ebuild
index 93bd9e36ed1c..7708dcf4a12c 100644
--- a/dev-python/logbook/logbook-0.5.0.ebuild
+++ b/dev-python/logbook/logbook-0.8.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.5.0.ebuild,v 1.5 2014/03/31 20:46:23 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.8.1.ebuild,v 1.1 2014/12/14 10:52:16 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_3} pypy pypy2_0 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
@@ -13,23 +13,29 @@ SRC_URI="https://github.com/mitsuhiko/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="doc test"
DISTUTILS_IN_SOURCE_BUILD=1
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
doc? ( >=dev-python/sphinx-1.1.3-r3[${PYTHON_USEDEP}] )"
+REDEPEND="dev-python/redis-py[${PYTHON_USEDEP}]"
-PATCHES=( "${FILESDIR}"/${PN}-0.4.2-objectsinv.patch \
- "${FILESDIR}"/${PN}-0.5-pypy-test-fix.patch )
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-objectsinv.patch )
+
+python_prepare_all() {
+ # Delete test file requiring local conncetion to redis server
+ rm tests/test_queues.py || die
+ distutils-r1_python_prepare_all
+}
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
- nosetests -w tests || die "Tests failed under ${EPYTHON}"
+ py.test tests || die "Tests failed under ${EPYTHON}"
}
python_install_all() {