summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-04-19 15:59:46 +0000
committerMike Gilbert <floppym@gentoo.org>2015-04-19 15:59:46 +0000
commitf36aa11add7ff91c9fcfc1fe37e1ee20d583fdcb (patch)
tree0229807488dd62ca5e0c3455244c989bc9619bc7 /dev-python
parentVersion bump. Drop old revision. (diff)
downloadgentoo-2-f36aa11add7ff91c9fcfc1fe37e1ee20d583fdcb.tar.gz
gentoo-2-f36aa11add7ff91c9fcfc1fe37e1ee20d583fdcb.tar.bz2
gentoo-2-f36aa11add7ff91c9fcfc1fe37e1ee20d583fdcb.zip
Simplify python_test function.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-debian/ChangeLog5
-rw-r--r--dev-python/python-debian/python-debian-0.1.26.ebuild8
2 files changed, 6 insertions, 7 deletions
diff --git a/dev-python/python-debian/ChangeLog b/dev-python/python-debian/ChangeLog
index cd677cd606d9..3698498c8c68 100644
--- a/dev-python/python-debian/ChangeLog
+++ b/dev-python/python-debian/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/python-debian
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-debian/ChangeLog,v 1.10 2015/04/13 09:31:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-debian/ChangeLog,v 1.11 2015/04/19 15:59:46 floppym Exp $
+
+ 19 Apr 2015; Mike Gilbert <floppym@gentoo.org> python-debian-0.1.26.ebuild:
+ Simplify python_test function.
*python-debian-0.1.26 (13 Apr 2015)
diff --git a/dev-python/python-debian/python-debian-0.1.26.ebuild b/dev-python/python-debian/python-debian-0.1.26.ebuild
index f72aa0e669da..8861ff0aae54 100644
--- a/dev-python/python-debian/python-debian-0.1.26.ebuild
+++ b/dev-python/python-debian/python-debian-0.1.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-debian/python-debian-0.1.26.ebuild,v 1.1 2015/04/13 09:31:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-debian/python-debian-0.1.26.ebuild,v 1.2 2015/04/19 15:59:46 floppym Exp $
EAPI="5"
@@ -35,11 +35,7 @@ python_compile_all() {
python_test() {
pushd tests > /dev/null || die
- local t
- for t in test_*.py ; do
- einfo "Running ${t} using ${EPYTHON}"
- "${PYTHON}" "${t}" || die "Testing failed with ${EPYTHON}"
- done
+ "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
popd > /dev/null || die
}