summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 16:55:54 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 16:55:54 +0000
commitf481bcf8a4b242811868259cea929c3d51db765c (patch)
tree85486243627cc44e64f8b033fd4383a13b20d1fa /dev-python
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-f481bcf8a4b242811868259cea929c3d51db765c.tar.gz
gentoo-2-f481bcf8a4b242811868259cea929c3d51db765c.tar.bz2
gentoo-2-f481bcf8a4b242811868259cea929c3d51db765c.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyatspi/ChangeLog7
-rw-r--r--dev-python/pyatspi/pyatspi-2.8.0.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-python/pyatspi/ChangeLog b/dev-python/pyatspi/ChangeLog
index 4bb238012d64..bc4168c091c4 100644
--- a/dev-python/pyatspi/ChangeLog
+++ b/dev-python/pyatspi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyatspi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/ChangeLog,v 1.20 2013/03/06 23:25:22 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/ChangeLog,v 1.21 2013/03/28 16:55:54 pacho Exp $
+
+*pyatspi-2.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +pyatspi-2.8.0.ebuild:
+ Version bump for Gnome 3.8
06 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org> -pyatspi-2.2.1.ebuild,
-pyatspi-2.4.0.ebuild, -pyatspi-2.6.0.ebuild:
diff --git a/dev-python/pyatspi/pyatspi-2.8.0.ebuild b/dev-python/pyatspi/pyatspi-2.8.0.ebuild
new file mode 100644
index 000000000000..62d2e8180af3
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.8.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyatspi/pyatspi-2.8.0.ebuild,v 1.1 2013/03/28 16:55:54 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit eutils gnome2 python-r1
+
+DESCRIPTION="Python binding to at-spi library"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="" # test
+
+# test suite is obsolete (at-spi-1.x era) and unpassable
+RESTRICT="test"
+
+COMMON_DEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+"
+RDEPEND="${COMMON_DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-${PV}[introspection]
+ !<gnome-extra/at-spi-1.32.0-r1
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=689957
+ epatch "${FILESDIR}/${PN}-2.6.0-examples-python3.patch"
+
+ gnome2_src_prepare
+
+ python_copy_sources
+}
+
+src_configure() {
+ G2CONF="${G2CONF} --disable-tests"
+ python_foreach_impl run_in_build_dir gnome2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_doscript examples/magFocusTracker.py
+ }
+ python_foreach_impl run_in_build_dir installing
+}
+
+run_in_build_dir() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "$@"
+ popd > /dev/null
+}