summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-06 03:27:15 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-06 03:27:15 +0000
commitfa63ef7bed48cece86554bfc5c8dfd14704502e3 (patch)
tree744ff38ed04a97da097674425bb31c41257639a1 /dev-python
parentAdd upstream patch to fix USE=-numa #518568 (diff)
downloadgentoo-2-fa63ef7bed48cece86554bfc5c8dfd14704502e3.tar.gz
gentoo-2-fa63ef7bed48cece86554bfc5c8dfd14704502e3.tar.bz2
gentoo-2-fa63ef7bed48cece86554bfc5c8dfd14704502e3.zip
bump, rm old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/click/ChangeLog8
-rw-r--r--dev-python/click/click-2.0.ebuild23
-rw-r--r--dev-python/click/click-2.4.ebuild8
-rw-r--r--dev-python/click/click-2.5.ebuild42
4 files changed, 56 insertions, 25 deletions
diff --git a/dev-python/click/ChangeLog b/dev-python/click/ChangeLog
index daf39c54829c..02150043bb87 100644
--- a/dev-python/click/ChangeLog
+++ b/dev-python/click/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/click
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/click/ChangeLog,v 1.2 2014/07/17 09:51:11 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/click/ChangeLog,v 1.3 2014/08/06 03:27:15 idella4 Exp $
+
+*click-2.5 (06 Aug 2014)
+
+ 06 Aug 2014; Ian Delaney <idella4@gentoo.org> +click-2.5.ebuild,
+ -click-2.0.ebuild, click-2.4.ebuild:
+ bump, rm old
*click-2.4 (17 Jul 2014)
diff --git a/dev-python/click/click-2.0.ebuild b/dev-python/click/click-2.0.ebuild
deleted file mode 100644
index a2ebfb73649e..000000000000
--- a/dev-python/click/click-2.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/click/click-2.0.ebuild,v 1.1 2014/06/08 00:36:37 rafaelmartins Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python package for creating beautiful command line interfaces"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-HOMEPAGE="http://click.pocoo.org/ http://pypi.python.org/pypi/click"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-# FIXME: tests docs and examples aren't being shipped with releases.
-# Asked upstream to fix this. Avoided using github snapshots for now. (rafaelmartins)
-IUSE=""
-
-RDEPEND="dev-python/colorama"
-DEPEND="${RDEPEND}"
diff --git a/dev-python/click/click-2.4.ebuild b/dev-python/click/click-2.4.ebuild
index a7e2e1934ba8..05de7e13a1ae 100644
--- a/dev-python/click/click-2.4.ebuild
+++ b/dev-python/click/click-2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/click/click-2.4.ebuild,v 1.1 2014/07/17 09:51:11 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/click/click-2.4.ebuild,v 1.2 2014/08/06 03:27:15 idella4 Exp $
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
@@ -21,6 +21,12 @@ RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
python_compile_all() {
use doc && emake -C docs html
}
diff --git a/dev-python/click/click-2.5.ebuild b/dev-python/click/click-2.5.ebuild
new file mode 100644
index 000000000000..6d807b5e612e
--- /dev/null
+++ b/dev-python/click/click-2.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/click/click-2.5.ebuild,v 1.1 2014/08/06 03:27:15 idella4 Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://click.pocoo.org/ http://pypi.python.org/pypi/click"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc examples test"
+
+RDEPEND="dev-python/colorama[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}