summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-02-11 03:35:39 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-02-11 03:35:39 +0000
commitfddac0f89dfe90565fe03747ae3ffffb2a6130ff (patch)
treed912d2e1c1d0d5d5797f479eddd94bdfecf56bd3 /dev-python
parentKeyword amd64-linux and x86-linux (diff)
downloadgentoo-2-fddac0f89dfe90565fe03747ae3ffffb2a6130ff.tar.gz
gentoo-2-fddac0f89dfe90565fe03747ae3ffffb2a6130ff.tar.bz2
gentoo-2-fddac0f89dfe90565fe03747ae3ffffb2a6130ff.zip
Initial import
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/llvmmath/ChangeLog9
-rw-r--r--dev-python/llvmmath/Manifest3
-rw-r--r--dev-python/llvmmath/llvmmath-0.1.2.ebuild29
-rw-r--r--dev-python/llvmmath/metadata.xml13
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/llvmmath/ChangeLog b/dev-python/llvmmath/ChangeLog
new file mode 100644
index 000000000000..a38f6922efa2
--- /dev/null
+++ b/dev-python/llvmmath/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/llvmmath
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/llvmmath/ChangeLog,v 1.1 2014/02/11 03:35:39 bicatali Exp $
+
+*llvmmath-0.1.2 (11 Feb 2014)
+
+ 11 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> +llvmmath-0.1.2.ebuild,
+ +metadata.xml:
+ Initial import
diff --git a/dev-python/llvmmath/Manifest b/dev-python/llvmmath/Manifest
new file mode 100644
index 000000000000..e62cf55cf50a
--- /dev/null
+++ b/dev-python/llvmmath/Manifest
@@ -0,0 +1,3 @@
+DIST llvmmath-0.1.2.tar.gz 46693 SHA256 6664988134572340eb01591c92f74b0ecf39a8e892a81c76274862b80944bda3 SHA512 7ac7a58d0c76d4badaa67b71ec852d9d87411edc3e0c16283741ba183fcee4b6c775d9e61c66b7c6bab24939796abecff6fe5ed06028e5635d8883dbb16d2f6c WHIRLPOOL 674be56ec12298c19e8ae7e0aa3cf33f72a7dda3e851c165eecf3d529cafa50d1991854fe199a3b8b467eb7a365931327a94545ca1e643af098a66f20a80428c
+EBUILD llvmmath-0.1.2.ebuild 837 SHA256 4f6fb56e30ba69a0825aea0063f9ed954d293c4065f7e37e61aac50acd06ab03 SHA512 24fce3a259316601f6170f50c573cb9973f2827a844e28dfb8fcffc9a88a22a2939f9d2d43e083732441db7cb33437334e9d2d0451a004c232830fefa2bfb10c WHIRLPOOL d8e973e0357e95a7823ffecee0abb3681b0d6569f009ee0af6088158bf40ba3afa00753fe512c0d9a69810075dfa750cf32dc54219c420936163e2857c50c6f3
+MISC metadata.xml 573 SHA256 2220a4fa7ffe0e71fea478c2a7259830934e46f3bda22d0ada83b074c3183313 SHA512 816c5ede6cc1ae70d6105d345ae175c706d3e4d97d0c3442caf85d9d7f0dd5868ac8ae738232c4437ece9b2efdcb9981c55b48355c5b55089542fe95bdcfbc30 WHIRLPOOL 3881f5e54ee865682abe5eec3ca26c94d9a097d4eb780327be69561f9ebe62e87e1c122bebd0011d1fdd543975a4c35a3ea6c7355a0ddd08c9ab8603191c0795
diff --git a/dev-python/llvmmath/llvmmath-0.1.2.ebuild b/dev-python/llvmmath/llvmmath-0.1.2.ebuild
new file mode 100644
index 000000000000..3e14f65aa0fa
--- /dev/null
+++ b/dev-python/llvmmath/llvmmath-0.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/llvmmath/llvmmath-0.1.2.ebuild,v 1.1 2014/02/11 03:35:39 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="LLVM math library for Python"
+HOMEPAGE="https://github.com/ContinuumIO/llvmmath"
+SRC_URI="https://github.com/ContinuumIO/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/llvmpy[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd "${BUILD_DIR}"/lib* || die
+ ${PYTHON} -c 'import sys,llvmmath; sys.exit(llvmmath.test())' || die
+}
diff --git a/dev-python/llvmmath/metadata.xml b/dev-python/llvmmath/metadata.xml
new file mode 100644
index 000000000000..b24a57aa0088
--- /dev/null
+++ b/dev-python/llvmmath/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The purpose of this project is to provide portable math functions,
+ many of which are in C99 and not available on all platforms. It is
+ based on NumPy's umath and tries to support all floating point and
+ complex types.
+ The library can be compiled with any C compiler, or to LLVM assembly
+ using Clang, to be linked into modules containing functions for jitting.
+</longdescription>
+</pkgmetadata>