summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2013-07-09 10:50:53 +0000
committerDavide Pesavento <pesa@gentoo.org>2013-07-09 10:50:53 +0000
commit561b179a4cbe52c625ab418dde371266df8afb8c (patch)
tree194d4a5a42f66e314559e4d1a1811f88e40f416f /dev-qt/qtopenvg/qtopenvg-4.8.5.ebuild
parentVersion bump. (diff)
downloadgentoo-2-561b179a4cbe52c625ab418dde371266df8afb8c.tar.gz
gentoo-2-561b179a4cbe52c625ab418dde371266df8afb8c.tar.bz2
gentoo-2-561b179a4cbe52c625ab418dde371266df8afb8c.zip
Version bump.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 17A85C72)
Diffstat (limited to 'dev-qt/qtopenvg/qtopenvg-4.8.5.ebuild')
-rw-r--r--dev-qt/qtopenvg/qtopenvg-4.8.5.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-qt/qtopenvg/qtopenvg-4.8.5.ebuild b/dev-qt/qtopenvg/qtopenvg-4.8.5.ebuild
new file mode 100644
index 000000000000..8b6653418731
--- /dev/null
+++ b/dev-qt/qtopenvg/qtopenvg-4.8.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-qt/qtopenvg/qtopenvg-4.8.5.ebuild,v 1.1 2013/07/09 10:50:53 pesa Exp $
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The OpenVG module for the Qt toolkit"
+SLOT="4"
+if [[ ${QT4_BUILD_TYPE} == live ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+IUSE="qt3support"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}[aqua=,debug=,qt3support=]
+ ~dev-qt/qtgui-${PV}[aqua=,debug=,egl,qt3support=]
+ media-libs/mesa[egl,openvg]
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/openvg
+ src/plugins/graphicssystems/openvg"
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/QtCore
+ include/QtGui
+ include/QtOpenVG
+ src/corelib
+ src/gui
+ src/openvg
+ src/plugins
+ src/3rdparty"
+
+ QCONFIG_ADD="openvg"
+ QCONFIG_DEFINE="QT_OPENVG"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ gltype="desktop"
+
+ myconf+="
+ -openvg -egl
+ $(qt_use qt3support)"
+
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+
+ # touch the available graphics systems
+ dodir /usr/share/qt4/graphicssystems
+ echo "experimental" > "${ED}"/usr/share/qt4/graphicssystems/openvg || die
+}