summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-01-01 10:21:13 +0000
committerHans de Graaff <graaff@gentoo.org>2015-01-01 10:21:13 +0000
commit739b51c206649be3a78b91667d27c517e4ffd787 (patch)
tree7e74cc9afd3ffa4079ca43c96f81c620f319bc5f /dev-ruby/actionmailer
parentVersion bump for Rails 4.2. Dropped keywords tracked in bug 534186. (diff)
downloadgentoo-2-739b51c206649be3a78b91667d27c517e4ffd787.tar.gz
gentoo-2-739b51c206649be3a78b91667d27c517e4ffd787.tar.bz2
gentoo-2-739b51c206649be3a78b91667d27c517e4ffd787.zip
Version bump for Rails 4.2. Dropped keywords tracked in bug 534186.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/actionmailer')
-rw-r--r--dev-ruby/actionmailer/ChangeLog9
-rw-r--r--dev-ruby/actionmailer/actionmailer-4.2.0.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-ruby/actionmailer/ChangeLog b/dev-ruby/actionmailer/ChangeLog
index 192bc53f625e..d67802aa1d15 100644
--- a/dev-ruby/actionmailer/ChangeLog
+++ b/dev-ruby/actionmailer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/actionmailer
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.278 2014/12/20 07:30:10 graaff Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/ChangeLog,v 1.279 2015/01/01 10:21:13 graaff Exp $
+
+*actionmailer-4.2.0 (01 Jan 2015)
+
+ 01 Jan 2015; Hans de Graaff <graaff@gentoo.org> +actionmailer-4.2.0.ebuild:
+ Version bump for Rails 4.2. Dropped keywords tracked in bug 534186.
20 Dec 2014; Hans de Graaff <graaff@gentoo.org> -actionmailer-3.2.20.ebuild,
-actionmailer-4.0.11.ebuild, -actionmailer-4.1.7.ebuild:
diff --git a/dev-ruby/actionmailer/actionmailer-4.2.0.ebuild b/dev-ruby/actionmailer/actionmailer-4.2.0.ebuild
new file mode 100644
index 000000000000..de5827f16c5e
--- /dev/null
+++ b/dev-ruby/actionmailer/actionmailer-4.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionmailer/actionmailer-4.2.0.ebuild,v 1.1 2015/01/01 10:21:13 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="actionmailer.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Framework for designing email-service layers"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/actionview-${PV}
+ ~dev-ruby/activejob-${PV}
+ >=dev-ruby/mail-2.5.4:2.5
+ >=dev-ruby/rails-dom-testing-1.0.5:1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ dev-ruby/mocha:0.14
+)"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/\/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+
+ # Avoid a test failing only on attachment ordering, since this is a
+ # security release.
+ sed -i -e '/adding inline attachments while rendering mail works/askip "gentoo: fails on ordering"' test/base_test.rb || die
+}