summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-04-20 07:18:36 +0000
committerHans de Graaff <graaff@gentoo.org>2012-04-20 07:18:36 +0000
commit834e23a9d51ae62b1e450e217c15858d6e853236 (patch)
tree500c391d927fc50d319beed896d423f6c5d13dcf /dev-ruby/activemodel
parentVersion bump. (diff)
downloadgentoo-2-834e23a9d51ae62b1e450e217c15858d6e853236.tar.gz
gentoo-2-834e23a9d51ae62b1e450e217c15858d6e853236.tar.bz2
gentoo-2-834e23a9d51ae62b1e450e217c15858d6e853236.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.2.3.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 63ee421d72d9..5576795b7917 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.24 2012/04/04 11:43:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.25 2012/04/20 07:18:36 graaff Exp $
+
+*activemodel-3.2.3 (20 Apr 2012)
+
+ 20 Apr 2012; Hans de Graaff <graaff@gentoo.org> +activemodel-3.2.3.ebuild:
+ Version bump.
*activemodel-3.1.4 (04 Apr 2012)
diff --git a/dev-ruby/activemodel/activemodel-3.2.3.ebuild b/dev-ruby/activemodel/activemodel-3.2.3.ebuild
new file mode 100644
index 000000000000..307e94a7e992
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.2.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.3.ebuild,v 1.1 2012/04/20 07:18:36 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.0.0
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}