summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-03 05:38:05 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-03 05:38:05 +0000
commitb725f7e1e9f5efa991ea1d0e245f4bf6a79f8444 (patch)
tree5b393e89255376277f8242f6c8ad9e9618747418 /dev-ruby/activemodel
parentVersion bump to Rails 3.2.19 for security bug 516084. (diff)
downloadgentoo-2-b725f7e1e9f5efa991ea1d0e245f4bf6a79f8444.tar.gz
gentoo-2-b725f7e1e9f5efa991ea1d0e245f4bf6a79f8444.tar.bz2
gentoo-2-b725f7e1e9f5efa991ea1d0e245f4bf6a79f8444.zip
Version bump to Rails 3.2.19 for security bug 516084.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.2.19.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 5e3946b73f6a..56bbb11df2c6 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.81 2014/06/26 20:06:34 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.82 2014/07/03 05:38:05 graaff Exp $
+
+*activemodel-3.2.19 (03 Jul 2014)
+
+ 03 Jul 2014; Hans de Graaff <graaff@gentoo.org> +activemodel-3.2.19.ebuild:
+ Version bump to Rails 3.2.19 for security bug 516084.
*activemodel-4.1.2 (26 Jun 2014)
diff --git a/dev-ruby/activemodel/activemodel-3.2.19.ebuild b/dev-ruby/activemodel/activemodel-3.2.19.ebuild
new file mode 100644
index 000000000000..502393c8b17c
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.2.19.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.19.ebuild,v 1.1 2014/07/03 05:38:05 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.0.0:3
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.13.0:0.13
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/cases/helper.rb || die
+
+ # Fix bcrypt dependency since bcrypt uses semantic versioning.
+ sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' lib/active_model/secure_password.rb || die
+}