summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-11-29 14:53:09 +0000
committerHans de Graaff <graaff@gentoo.org>2013-11-29 14:53:09 +0000
commitb27077e1a4c755af67647da05b8c77c324655fe8 (patch)
tree6babc1521a25b4835cb5fb21544d550fbb58a972 /dev-ruby/activerecord
parentRemove masked Rails 3.1. (diff)
downloadgentoo-2-b27077e1a4c755af67647da05b8c77c324655fe8.tar.gz
gentoo-2-b27077e1a4c755af67647da05b8c77c324655fe8.tar.bz2
gentoo-2-b27077e1a4c755af67647da05b8c77c324655fe8.zip
Remove masked Rails 3.1.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activerecord')
-rw-r--r--dev-ruby/activerecord/ChangeLog5
-rw-r--r--dev-ruby/activerecord/activerecord-3.1.12.ebuild65
2 files changed, 4 insertions, 66 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index bc3be0fb9977..82d947dff2dc 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.247 2013/11/10 14:42:04 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.248 2013/11/29 14:53:09 graaff Exp $
+
+ 29 Nov 2013; Hans de Graaff <graaff@gentoo.org> -activerecord-3.1.12.ebuild:
+ Remove masked Rails 3.1.
10 Nov 2013; Hans de Graaff <graaff@gentoo.org> -activerecord-3.2.13.ebuild,
-activerecord-3.2.14.ebuild:
diff --git a/dev-ruby/activerecord/activerecord-3.1.12.ebuild b/dev-ruby/activerecord/activerecord-3.1.12.ebuild
deleted file mode 100644
index 3aee892ca8ea..000000000000
--- a/dev-ruby/activerecord/activerecord-3.1.12.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.1.12.ebuild,v 1.2 2013/10/13 16:04:35 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ruby19"
-
-# this is not null so that the dependencies will actually be filled
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
-HOMEPAGE="http://rubyforge.org/projects/activerecord/"
-SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="3.1"
-KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="mysql postgres sqlite3"
-
-RUBY_S="rails-rails-*/activerecord"
-
-ruby_add_rdepend "~dev-ruby/activesupport-${PV}
- ~dev-ruby/activemodel-${PV}
- >=dev-ruby/arel-2.2.3:2.1
- >=dev-ruby/tzinfo-0.3.29:0
- sqlite3? ( >=dev-ruby/sqlite3-1.3.4 )
- mysql? ( >=dev-ruby/mysql2-0.3.6:0.3 )
- postgres? ( >=dev-ruby/pg-0.11.0 )"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/bundler
- ~dev-ruby/actionpack-${PV}
- >=dev-ruby/sqlite3-1.3.3
- >=dev-ruby/mocha-0.13.0
- virtual/ruby-test-unit
- )"
-
-all_ruby_prepare() {
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e '/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|"mysql"\|ruby-prof\|benchmark-ips\)/d' ../Gemfile || die
- sed -i -e '/\(rack-ssl\|thor\)/d' ../railties/railties.gemspec || die
- sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
- sed -i -e "s/, '< 1.3'//" ../activesupport/activesupport.gemspec || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- if use sqlite3; then
- TRAVIS=true ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
- fi
- ;;
- esac
-}