summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-01-07 07:03:48 +0000
committerHans de Graaff <graaff@gentoo.org>2015-01-07 07:03:48 +0000
commit33850f5798e82ddda3bfa7915efa8986c56bc5ce (patch)
tree595f711cb069831a2af9d31ed705f255b61bdb2d /dev-ruby/activesupport
parentBump (diff)
downloadgentoo-2-33850f5798e82ddda3bfa7915efa8986c56bc5ce.tar.gz
gentoo-2-33850f5798e82ddda3bfa7915efa8986c56bc5ce.tar.bz2
gentoo-2-33850f5798e82ddda3bfa7915efa8986c56bc5ce.zip
Version bumps.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog9
-rw-r--r--dev-ruby/activesupport/activesupport-4.0.13.ebuild61
-rw-r--r--dev-ruby/activesupport/activesupport-4.1.9.ebuild61
3 files changed, 130 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index eecee0e7d41f..08672c6e4d7a 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.278 2015/01/01 10:18:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.279 2015/01/07 07:03:48 graaff Exp $
+
+*activesupport-4.1.9 (07 Jan 2015)
+*activesupport-4.0.13 (07 Jan 2015)
+
+ 07 Jan 2015; Hans de Graaff <graaff@gentoo.org> +activesupport-4.0.13.ebuild,
+ +activesupport-4.1.9.ebuild:
+ Version bumps.
*activesupport-4.2.0 (01 Jan 2015)
diff --git a/dev-ruby/activesupport/activesupport-4.0.13.ebuild b/dev-ruby/activesupport/activesupport-4.0.13.ebuild
new file mode 100644
index 000000000000..a3670184f057
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-4.0.13.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-4.0.13.ebuild,v 1.1 2015/01/07 07:03:48 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/multi_json-1.3:0
+ >=dev-ruby/i18n-0.6.9:0.6
+ >=dev-ruby/tzinfo-0.3.37:0
+ >=dev-ruby/minitest-4.2:0
+ >=dev-ruby/thread_safe-0.1:0
+ !!<dev-ruby/activesupport-3.0.11-r1:3.0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/libxml-2.0.0
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure a compatible version of minitest is used everywhere.
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 4.2'/" lib/active_support/test_case.rb || die
+ sed -i -e "1igem 'minitest', '~> 4.2'" test/abstract_unit.rb || die
+
+ # Avoid test that seems to be broken by lack of DST.
+ sed -i -e '324 s:^:#:' test/core_ext/string_ext_test.rb || die
+}
diff --git a/dev-ruby/activesupport/activesupport-4.1.9.ebuild b/dev-ruby/activesupport/activesupport-4.1.9.ebuild
new file mode 100644
index 000000000000..2a81eab1b348
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-4.1.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-4.1.9.ebuild,v 1.1 2015/01/07 07:03:48 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ >=dev-ruby/i18n-0.6.9:0.6
+ >=dev-ruby/json-1.7.7:0
+ >=dev-ruby/tzinfo-1.1:1
+ >=dev-ruby/minitest-5.1:5
+ >=dev-ruby/thread_safe-0.1:0"
+
+# memcache-client, nokogiri, and builder are not strictly
+# needed, but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-2.2.1
+ >=dev-ruby/nokogiri-1.4.5
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/libxml-2.0.0
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Set test environment to our hand.
+# rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Avoid test that seems to be broken by lack of DST.
+ sed -i -e '369 s:^:#:' test/core_ext/string_ext_test.rb || die
+
+ # Avoid test that fails with Minitest 5.4 since that already defines
+ # a string E in its TestCase.
+ rm test/core_ext/marshal_test.rb || die
+ sed -i -e '/test_const_missing_in_anonymous_modules/askip "gentoo minitest"' test/dependencies_test.rb || die
+}