summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-05-08 18:25:08 +0000
committerHans de Graaff <graaff@gentoo.org>2012-05-08 18:25:08 +0000
commitbc5607ed0c8d721c7467b1b00dd01723d777b798 (patch)
treebbbd458de4954a290ec5b08c90296834697bf5ed /dev-ruby/addressable
parentStable on amd64 wrt bug #414241 (diff)
downloadgentoo-2-bc5607ed0c8d721c7467b1b00dd01723d777b798.tar.gz
gentoo-2-bc5607ed0c8d721c7467b1b00dd01723d777b798.tar.bz2
gentoo-2-bc5607ed0c8d721c7467b1b00dd01723d777b798.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/addressable')
-rw-r--r--dev-ruby/addressable/ChangeLog7
-rw-r--r--dev-ruby/addressable/addressable-2.2.8.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ruby/addressable/ChangeLog b/dev-ruby/addressable/ChangeLog
index d807cb671c89..5c0b345190e6 100644
--- a/dev-ruby/addressable/ChangeLog
+++ b/dev-ruby/addressable/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/addressable
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.20 2012/04/07 06:17:46 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/ChangeLog,v 1.21 2012/05/08 18:25:08 graaff Exp $
+
+*addressable-2.2.8 (08 May 2012)
+
+ 08 May 2012; Hans de Graaff <graaff@gentoo.org> +addressable-2.2.8.ebuild:
+ Version bump.
*addressable-2.2.7 (07 Apr 2012)
diff --git a/dev-ruby/addressable/addressable-2.2.8.ebuild b/dev-ruby/addressable/addressable-2.2.8.ebuild
new file mode 100644
index 000000000000..f926a560ba73
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.2.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/addressable/addressable-2.2.8.ebuild,v 1.1 2012/05/08 18:25:08 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_TASK_TEST="spec:normal"
+
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library."
+HOMEPAGE="http://addressable.rubyforge.org/"
+
+LICENSE="as-is"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm tasks/rspec.rake || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I lib -S rspec spec || die "Tests failed."
+}