summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-04-08 06:45:00 +0000
committerHans de Graaff <graaff@gentoo.org>2014-04-08 06:45:00 +0000
commiteff2db85446a1d3b7a1be9b3aeb99de1bb58e9a7 (patch)
treeaf3cec96c28211a31e56d7696f0d4374d7b69c15 /dev-ruby/amatch
parentlol python2.6 (diff)
downloadgentoo-2-eff2db85446a1d3b7a1be9b3aeb99de1bb58e9a7.tar.gz
gentoo-2-eff2db85446a1d3b7a1be9b3aeb99de1bb58e9a7.tar.bz2
gentoo-2-eff2db85446a1d3b7a1be9b3aeb99de1bb58e9a7.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/amatch')
-rw-r--r--dev-ruby/amatch/ChangeLog9
-rw-r--r--dev-ruby/amatch/amatch-0.3.0.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-ruby/amatch/ChangeLog b/dev-ruby/amatch/ChangeLog
index 87ebaf93c8c2..ebdceb2dd3a7 100644
--- a/dev-ruby/amatch/ChangeLog
+++ b/dev-ruby/amatch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/amatch
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amatch/ChangeLog,v 1.38 2013/11/17 20:49:29 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amatch/ChangeLog,v 1.39 2014/04/08 06:45:00 graaff Exp $
+
+*amatch-0.3.0 (08 Apr 2014)
+
+ 08 Apr 2014; Hans de Graaff <graaff@gentoo.org> +amatch-0.3.0.ebuild:
+ Version bump.
17 Nov 2013; Manuel Rüger <mrueg@gentoo.org> -amatch-0.2.11.ebuild:
Cleanup old.
diff --git a/dev-ruby/amatch/amatch-0.3.0.ebuild b/dev-ruby/amatch/amatch-0.3.0.ebuild
new file mode 100644
index 000000000000..275d47f0ee0f
--- /dev/null
+++ b/dev-ruby/amatch/amatch-0.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amatch/amatch-0.3.0.ebuild,v 1.1 2014/04/08 06:45:00 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Approximate Matching Extension for Ruby"
+HOMEPAGE="http://flori.github.com/amatch/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/tins-0.3"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext V=1
+ cp ext/amatch_ext$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S testrb tests/* || die
+}