summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-09-04 02:17:56 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-09-04 02:17:56 +0000
commit9ba55661bd08dbb53eca31f62ac44ed52d7da321 (patch)
tree3c30afa27c8bb1778e1bb921a586e18abc045cd5 /dev-ruby/astrolabe/astrolabe-1.3.0.ebuild
parentFix typo. (diff)
downloadgentoo-2-9ba55661bd08dbb53eca31f62ac44ed52d7da321.tar.gz
gentoo-2-9ba55661bd08dbb53eca31f62ac44ed52d7da321.tar.bz2
gentoo-2-9ba55661bd08dbb53eca31f62ac44ed52d7da321.zip
Initial version.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/astrolabe/astrolabe-1.3.0.ebuild')
-rw-r--r--dev-ruby/astrolabe/astrolabe-1.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/astrolabe/astrolabe-1.3.0.ebuild b/dev-ruby/astrolabe/astrolabe-1.3.0.ebuild
new file mode 100644
index 000000000000..dd15b9b6ed1a
--- /dev/null
+++ b/dev-ruby/astrolabe/astrolabe-1.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/astrolabe/astrolabe-1.3.0.ebuild,v 1.1 2014/09/04 02:17:56 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An object-oriented AST extension for Parser"
+HOMEPAGE="https://github.com/yujinakayama/astrolabe"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/parser-2.2.0_pre3"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ # Fix Specs until RSpec3 is available
+ sed -i -e "/mocks.verify_partial_doubles/ s/^/#/" spec/spec_helper.rb || die
+ sed -i -e "s/is_expected.to/should/" spec/astrolabe/node_spec.rb || die
+}