summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-15 23:38:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-15 23:38:10 +0000
commite8f876716b1aa5480f7352df156ca1bdf7e4a4ba (patch)
tree1ebf903e3c29d4598a57658a3631dd543d8d14fb /dev-ruby/bitescript/bitescript-0.0.5.ebuild
parentUse wxwidgets.eclass. (diff)
downloadgentoo-2-e8f876716b1aa5480f7352df156ca1bdf7e4a4ba.tar.gz
gentoo-2-e8f876716b1aa5480f7352df156ca1bdf7e4a4ba.tar.bz2
gentoo-2-e8f876716b1aa5480f7352df156ca1bdf7e4a4ba.zip
Initial import of bitescript ebuild for JRuby. Far from perfect, as we still try to use the script with Ruby 1.8, but it's working if you're using 'jruby -S'.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/bitescript/bitescript-0.0.5.ebuild')
-rw-r--r--dev-ruby/bitescript/bitescript-0.0.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/bitescript/bitescript-0.0.5.ebuild b/dev-ruby/bitescript/bitescript-0.0.5.ebuild
new file mode 100644
index 000000000000..8d53441f4f7d
--- /dev/null
+++ b/dev-ruby/bitescript/bitescript-0.0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bitescript/bitescript-0.0.5.ebuild,v 1.1 2010/02/15 23:38:10 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="jruby"
+
+RUBY_FAKGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOC_DIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="BiteScript is a Ruby DSL for generating Java bytecode and classes."
+HOMEPAGE="http://kenai.com/projects/bitescript"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/* || die
+}