summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 13:12:13 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 13:12:13 +0000
commit73bfd769d18c5223e2bdc330157df0c642d07e88 (patch)
tree0448eafdad0b4134f914fd51e44e3a9dfc8f56f7 /dev-ruby/bluecloth
parenttest/unit is a build-time dependency. (diff)
downloadgentoo-2-73bfd769d18c5223e2bdc330157df0c642d07e88.tar.gz
gentoo-2-73bfd769d18c5223e2bdc330157df0c642d07e88.tar.bz2
gentoo-2-73bfd769d18c5223e2bdc330157df0c642d07e88.zip
Cleanup old versions; avoid setting ruby19 on ruby.eclass-based version, update to new syntax.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/bluecloth')
-rw-r--r--dev-ruby/bluecloth/ChangeLog8
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.0.5-r1.ebuild43
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.0.5.ebuild6
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.0.6.ebuild42
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.0.7.ebuild12
5 files changed, 18 insertions, 93 deletions
diff --git a/dev-ruby/bluecloth/ChangeLog b/dev-ruby/bluecloth/ChangeLog
index 2e7b55f0e2d1..406e0c1bc65c 100644
--- a/dev-ruby/bluecloth/ChangeLog
+++ b/dev-ruby/bluecloth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/bluecloth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.35 2010/01/29 18:47:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/ChangeLog,v 1.36 2010/05/22 13:12:13 flameeyes Exp $
+
+ 22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ bluecloth-2.0.5.ebuild, -bluecloth-2.0.5-r1.ebuild,
+ -bluecloth-2.0.6.ebuild, bluecloth-2.0.7.ebuild:
+ Cleanup old versions; avoid setting ruby19 on ruby.eclass-based version,
+ update to new syntax.
29 Jan 2010; Raúl Porcel <armin76@gentoo.org> bluecloth-2.0.5-r1.ebuild,
bluecloth-2.0.6.ebuild, bluecloth-2.0.7.ebuild:
diff --git a/dev-ruby/bluecloth/bluecloth-2.0.5-r1.ebuild b/dev-ruby/bluecloth/bluecloth-2.0.5-r1.ebuild
deleted file mode 100644
index 0604eb4b2be4..000000000000
--- a/dev-ruby/bluecloth/bluecloth-2.0.5-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.0.5-r1.ebuild,v 1.6 2010/01/29 18:47:05 armin76 Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A Ruby implementation of Markdown"
-HOMEPAGE="http://www.deveiate.org/projects/BlueCloth"
-SRC_URI="http://www.deveiate.org/code/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend ">=dev-ruby/rdoc-2.4.1"
-ruby_add_bdepend test "dev-ruby/rspec
- dev-ruby/diff-lcs"
-
-each_ruby_compile() {
- ${RUBY} -S rake ext/Makefile || die
-
- emake -C ext || die
-}
-
-each_ruby_install() {
- each_fakegem_install
- ruby_fakegem_newins ext/bluecloth_ext.so lib/bluecloth_ext.so
-}
-
-all_ruby_install() {
- ruby_fakegem_binwrapper bluecloth
- dodoc ChangeLog README || die
-
- if use doc; then
- pushd docs/api
- dohtml -r * || die
- popd
- fi
-}
diff --git a/dev-ruby/bluecloth/bluecloth-2.0.5.ebuild b/dev-ruby/bluecloth/bluecloth-2.0.5.ebuild
index 2d455150e62b..0615668620b6 100644
--- a/dev-ruby/bluecloth/bluecloth-2.0.5.ebuild
+++ b/dev-ruby/bluecloth/bluecloth-2.0.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.0.5.ebuild,v 1.6 2009/12/22 19:04:26 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.0.5.ebuild,v 1.7 2010/05/22 13:12:13 flameeyes Exp $
inherit ruby gems
@@ -12,6 +12,6 @@ SLOT="0"
KEYWORDS="amd64 ia64 ppc ppc64 x86"
IUSE=""
-USE_RUBY="ruby18 ruby19"
+USE_RUBY="ruby18"
DEPEND=">=dev-lang/ruby-1.8"
RDEPEND="${DEPEND}"
diff --git a/dev-ruby/bluecloth/bluecloth-2.0.6.ebuild b/dev-ruby/bluecloth/bluecloth-2.0.6.ebuild
deleted file mode 100644
index c51845b5511b..000000000000
--- a/dev-ruby/bluecloth/bluecloth-2.0.6.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.0.6.ebuild,v 1.2 2010/01/29 18:47:05 armin76 Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19"
-
-RUBY_FAKEGEM_VERSION="${PV/_pre/.pre}"
-
-RUBY_FAKEGEM_EXTRADOC="ChangeLog README"
-RUBY_FAKEGEM_DOCDIR="docs/api"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A Ruby implementation of Markdown"
-HOMEPAGE="http://www.deveiate.org/projects/BlueCloth"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend ">=dev-ruby/rdoc-2.4.1 dev-ruby/rake-compiler"
-ruby_add_bdepend test "dev-ruby/rspec
- dev-ruby/diff-lcs"
-
-all_ruby_prepare() {
- # The Rakefile uses the rubygems' package_task unconditionally,
- # but this breaks when we don't install rubygems proper (like for
- # Ruby 1.9 or JRuby). For this reason, patch it away. It should
- # really be submitted upstream so that, if missing, only the
- # packaging tasks will be ignored.
- sed -i \
- -e '/^\(Gem\|Rake\)::PackageTask/, /^end/ s:^:#:' \
- -e '/package_task/s:^:#:' \
- -e '/task :package/s:^:#:' \
- rake/packaging.rb || die
-}
-
-each_ruby_compile() {
- ${RUBY} -S rake compile || die "extension build failed"
-}
diff --git a/dev-ruby/bluecloth/bluecloth-2.0.7.ebuild b/dev-ruby/bluecloth/bluecloth-2.0.7.ebuild
index cca20a199394..eb66363ac49b 100644
--- a/dev-ruby/bluecloth/bluecloth-2.0.7.ebuild
+++ b/dev-ruby/bluecloth/bluecloth-2.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.0.7.ebuild,v 1.2 2010/01/29 18:47:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bluecloth/bluecloth-2.0.7.ebuild,v 1.3 2010/05/22 13:12:13 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18 ruby19"
@@ -20,9 +20,13 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE=""
-ruby_add_bdepend ">=dev-ruby/rdoc-2.4.1 dev-ruby/rake-compiler"
-ruby_add_bdepend test "dev-ruby/rspec
- dev-ruby/diff-lcs"
+ruby_add_bdepend "
+ >=dev-ruby/rdoc-2.4.1
+ dev-ruby/rake-compiler
+ test? (
+ dev-ruby/rspec
+ dev-ruby/diff-lcs
+ )"
all_ruby_prepare() {
# The Rakefile uses the rubygems' package_task unconditionally,