summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-12-15 08:21:26 +0000
committerHans de Graaff <graaff@gentoo.org>2012-12-15 08:21:26 +0000
commit9c2a10e7699f44a38f8af6fb7b9ba9f7c57fdcf6 (patch)
tree12366f70be29a932282ffbacffe87d3eb1de92f2 /dev-ruby/bourne/bourne-1.3.0.ebuild
parentAvoid installing empty docs, thanks to Tim Harder for discovering this (diff)
downloadgentoo-2-9c2a10e7699f44a38f8af6fb7b9ba9f7c57fdcf6.tar.gz
gentoo-2-9c2a10e7699f44a38f8af6fb7b9ba9f7c57fdcf6.tar.bz2
gentoo-2-9c2a10e7699f44a38f8af6fb7b9ba9f7c57fdcf6.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/bourne/bourne-1.3.0.ebuild')
-rw-r--r--dev-ruby/bourne/bourne-1.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/bourne/bourne-1.3.0.ebuild b/dev-ruby/bourne/bourne-1.3.0.ebuild
new file mode 100644
index 000000000000..fe688a942e3d
--- /dev/null
+++ b/dev-ruby/bourne/bourne-1.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bourne/bourne-1.3.0.ebuild,v 1.1 2012/12/15 08:21:26 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST="test:units test:acceptance"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extends mocha to allow detailed tracking and querying of stub and mock invocations."
+HOMEPAGE="http://github.com/thoughtbot/bourne"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/mocha-0.13*"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ -e '/dependency.*mocha/s:0.13.0:~> 0.13.0:' \
+ "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ sed -i -e '/bundler/d' Rakefile || die
+}