summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-12-31 07:36:03 +0000
committerHans de Graaff <graaff@gentoo.org>2014-12-31 07:36:03 +0000
commite4237055fbecde62b01e41a3da3f875875f57a44 (patch)
tree0f1182fe3a4d1d15c95ff36f04d2e29cf529e0cb /dev-ruby/capistrano
parentNote the removal of USE=tcpd support due to upstream #533462 by Martin Mokrejš. (diff)
downloadgentoo-2-e4237055fbecde62b01e41a3da3f875875f57a44.tar.gz
gentoo-2-e4237055fbecde62b01e41a3da3f875875f57a44.tar.bz2
gentoo-2-e4237055fbecde62b01e41a3da3f875875f57a44.zip
Version bump. Capistrano 2.x can still be called directly with the new cap-2 command for compatibility.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/capistrano')
-rw-r--r--dev-ruby/capistrano/ChangeLog10
-rw-r--r--dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild49
-rw-r--r--dev-ruby/capistrano/capistrano-3.3.5.ebuild35
3 files changed, 93 insertions, 1 deletions
diff --git a/dev-ruby/capistrano/ChangeLog b/dev-ruby/capistrano/ChangeLog
index 772de10be493..7534ddc6fadc 100644
--- a/dev-ruby/capistrano/ChangeLog
+++ b/dev-ruby/capistrano/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/capistrano
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.104 2014/11/22 20:14:33 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.105 2014/12/31 07:36:03 graaff Exp $
+
+*capistrano-3.3.5 (31 Dec 2014)
+*capistrano-2.15.5-r2 (31 Dec 2014)
+
+ 31 Dec 2014; Hans de Graaff <graaff@gentoo.org> +capistrano-2.15.5-r2.ebuild,
+ +capistrano-3.3.5.ebuild:
+ Version bump. Capistrano 2.x can still be called directly with the new cap-2
+ command for compatibility.
22 Nov 2014; Manuel Rüger <mrueg@gentoo.org> capistrano-2.15.5-r1.ebuild,
capistrano-2.15.5.ebuild:
diff --git a/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild b/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild
new file mode 100644
index 000000000000..db20fd6097e9
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild,v 1.1 2014/12/31 07:36:03 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.0.14
+ >=dev-ruby/net-sftp-2.0.2
+ >=dev-ruby/net-scp-1.0.2
+ >=dev-ruby/net-ssh-gateway-1.1.0
+ >=dev-ruby/highline-1.2.7"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha:0.12 )"
+
+RUBY_PATCHES=( ${P}-sudo-cleanup.patch )
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile test/utils.rb || die
+ sed -i -e '/pry/ s:^:#:' -e '4igem "mocha", "~>0.12.0"' test/utils.rb || die
+
+ # Avoid copy strategy tests since these fail in some cases due to
+ # complicated (aka unknown) interactions with other parts of the
+ # test suite.
+ rm test/deploy/strategy/copy_test.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper cap /usr/bin/cap-2 'gem "capistrano", "~>2.0"'
+}
diff --git a/dev-ruby/capistrano/capistrano-3.3.5.ebuild b/dev-ruby/capistrano/capistrano-3.3.5.ebuild
new file mode 100644
index 000000000000..f3da7b95082d
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-3.3.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-3.3.5.ebuild,v 1.1 2014/12/31 07:36:03 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capify.org/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/sshkit-1.3:0
+ >=dev-ruby/rake-10.0.0
+ dev-ruby/i18n
+ !!<dev-ruby/capistrano-2.15.5-r2"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha:0.12 )"
+
+pkg_postinst() {
+ einfo "Capistrano 3.1 has some breaking changes. Please check the CHANGELOG: http://goo.gl/SxB0lr"
+ einfo "If you're upgrading Capistrano from 2.x, we recommend to read the upgrade guide: http://goo.gl/4536kB"
+ einfo "The `deploy:restart` hook for passenger applications is now in a separate gem called capistrano-passenger. Just add it to your Gemfile and require it in your Capfile."
+}