summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-09 08:32:34 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-09 08:32:34 +0000
commit17e38a330ed1d7fe189fe388a179623c567ce394 (patch)
tree9a0b9a3646a3b888d97d2a1541981409d8b178cc /dev-ruby/daemons
parentRemove -Werror wrt #362675 by Diego Elio Pettenò <flameeyes@gentoo.org>. Rem... (diff)
downloadgentoo-2-17e38a330ed1d7fe189fe388a179623c567ce394.tar.gz
gentoo-2-17e38a330ed1d7fe189fe388a179623c567ce394.tar.bz2
gentoo-2-17e38a330ed1d7fe189fe388a179623c567ce394.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/daemons')
-rw-r--r--dev-ruby/daemons/ChangeLog7
-rw-r--r--dev-ruby/daemons/daemons-1.1.2.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-ruby/daemons/ChangeLog b/dev-ruby/daemons/ChangeLog
index 273a9310e2b4..7481c3fa2383 100644
--- a/dev-ruby/daemons/ChangeLog
+++ b/dev-ruby/daemons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/daemons
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/ChangeLog,v 1.52 2011/03/17 10:05:24 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/ChangeLog,v 1.53 2011/04/09 08:32:34 graaff Exp $
+
+*daemons-1.1.2 (09 Apr 2011)
+
+ 09 Apr 2011; Hans de Graaff <graaff@gentoo.org> +daemons-1.1.2.ebuild:
+ Version bump.
17 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org> daemons-1.1.0.ebuild:
ppc/ppc64 stable wrt #349877
diff --git a/dev-ruby/daemons/daemons-1.1.2.ebuild b/dev-ruby/daemons/daemons-1.1.2.ebuild
new file mode 100644
index 000000000000..43544ec1c796
--- /dev/null
+++ b/dev-ruby/daemons/daemons-1.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemons/daemons-1.1.2.ebuild,v 1.1 2011/04/09 08:32:34 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_EXTRADOC="Releases README TODO"
+RUBY_FAKEGEM_DOCDIR="html"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
+HOMEPAGE="http://daemons.rubyforge.org/"
+
+LICENSE="|| ( Ruby GPL-2 ) MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples || return
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples || die "Failed to install examples"
+}