summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-24 01:38:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-12-24 01:38:15 +0000
commitb984e1b618d2c5a4cb96d9c8ad55ac1df25bf2cd (patch)
tree83e88293a2067d508fab76cddab4dc77c97da775 /dev-ruby/dust
parentVersion bump. (diff)
downloadgentoo-2-b984e1b618d2c5a4cb96d9c8ad55ac1df25bf2cd.tar.gz
gentoo-2-b984e1b618d2c5a4cb96d9c8ad55ac1df25bf2cd.tar.bz2
gentoo-2-b984e1b618d2c5a4cb96d9c8ad55ac1df25bf2cd.zip
Revision bump: port to EAPI=4 and add ree18 support.
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/dust')
-rw-r--r--dev-ruby/dust/ChangeLog9
-rw-r--r--dev-ruby/dust/dust-0.1.6-r2.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-ruby/dust/ChangeLog b/dev-ruby/dust/ChangeLog
index 107d8ffc4c3c..c7edeca01526 100644
--- a/dev-ruby/dust/ChangeLog
+++ b/dev-ruby/dust/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/dust
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/dust/ChangeLog,v 1.6 2010/07/21 12:55:08 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/dust/ChangeLog,v 1.7 2011/12/24 01:38:15 flameeyes Exp $
+
+*dust-0.1.6-r2 (24 Dec 2011)
+
+ 24 Dec 2011; Diego E. Pettenò <flameeyes@gentoo.org> +dust-0.1.6-r2.ebuild:
+ Revision bump: port to EAPI=4 and add ree18 support.
21 Jul 2010; Christian Faulhammer <fauli@gentoo.org> dust-0.1.6-r1.ebuild:
stable x86, bug 321217
diff --git a/dev-ruby/dust/dust-0.1.6-r2.ebuild b/dev-ruby/dust/dust-0.1.6-r2.ebuild
new file mode 100644
index 000000000000..3ed9f531610d
--- /dev/null
+++ b/dev-ruby/dust/dust-0.1.6-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/dust/dust-0.1.6-r2.ebuild,v 1.1 2011/12/24 01:38:14 flameeyes Exp $
+
+EAPI="4"
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Descriptive block syntax definition for Test::Unit."
+HOMEPAGE="http://dust.rubyforge.org/"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+# Remove a long-obsolete rubygems method.
+all_ruby_prepare() {
+ sed -i '/manage_gems/d' rakefile.rb || die "Unable to update rakefile.rb"
+}
+
+each_ruby_prepare() {
+ sed -i '/manage_gems/d' rakefile.rb || die "Unable to update rakefile.rb"
+}