summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-25 00:28:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-01-25 00:28:24 +0000
commit3e6f0c043aa7dfdab2254b893693411c45ac162a (patch)
tree94c191b900b87415a3f4a8086563d8ad78b5a69e /dev-ruby/execjs/execjs-1.2.13-r1.ebuild
parentTake full maintenance of this package now that I am a developer. (diff)
downloadgentoo-2-3e6f0c043aa7dfdab2254b893693411c45ac162a.tar.gz
gentoo-2-3e6f0c043aa7dfdab2254b893693411c45ac162a.tar.bz2
gentoo-2-3e6f0c043aa7dfdab2254b893693411c45ac162a.zip
Fix installation of gemspec to declare the dependency over multi_json (compatibility with Bundler).
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/execjs/execjs-1.2.13-r1.ebuild')
-rw-r--r--dev-ruby/execjs/execjs-1.2.13-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/execjs/execjs-1.2.13-r1.ebuild b/dev-ruby/execjs/execjs-1.2.13-r1.ebuild
new file mode 100644
index 000000000000..3225e5ca15fe
--- /dev/null
+++ b/dev-ruby/execjs/execjs-1.2.13-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/execjs/execjs-1.2.13-r1.ebuild,v 1.1 2012/01/25 00:28:24 flameeyes Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="sstephenson"
+GITHUB_PROJECT="${PN}"
+RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="ExecJS lets you run JavaScript code from Ruby"
+HOMEPAGE="https://github.com/sstephenson/execjs"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/v${PV} -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/multi_json-1.0"
+
+# execjs supports various javascript runtimes. They are listed in order
+# as per the documentation. For now only include the ones already in the
+# tree.
+
+# therubyracer, therubyrhino, johnson, mustang, node.js, spidermonkey
+
+# spidermonkey doesn't pass the test suite:
+# https://github.com/sstephenson/execjs/issues/62
+
+RDEPEND="${RDEPEND} || ( net-libs/nodejs )"