summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-02-04 19:58:01 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-02-04 19:58:01 +0000
commit9a961a1d1003d528a9357104a26af9f933c23011 (patch)
treee2bcbb590fb811c8665163454730c8f0f0e777bb /dev-ruby/execjs
parentstable amd64 x86, wrt bug 538810 (diff)
downloadgentoo-2-9a961a1d1003d528a9357104a26af9f933c23011.tar.gz
gentoo-2-9a961a1d1003d528a9357104a26af9f933c23011.tar.bz2
gentoo-2-9a961a1d1003d528a9357104a26af9f933c23011.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/execjs')
-rw-r--r--dev-ruby/execjs/ChangeLog7
-rw-r--r--dev-ruby/execjs/execjs-2.3.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/execjs/ChangeLog b/dev-ruby/execjs/ChangeLog
index b0898ab7013e..488a6ef42953 100644
--- a/dev-ruby/execjs/ChangeLog
+++ b/dev-ruby/execjs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/execjs
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/execjs/ChangeLog,v 1.27 2015/01/24 09:50:35 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/execjs/ChangeLog,v 1.28 2015/02/04 19:58:01 mrueg Exp $
+
+*execjs-2.3.0 (04 Feb 2015)
+
+ 04 Feb 2015; Manuel Rüger <mrueg@gentoo.org> +execjs-2.3.0.ebuild:
+ Version bump.
24 Jan 2015; Agostino Sarubbo <ago@gentoo.org> execjs-2.2.2.ebuild:
Stable for x86, wrt bug #508540
diff --git a/dev-ruby/execjs/execjs-2.3.0.ebuild b/dev-ruby/execjs/execjs-2.3.0.ebuild
new file mode 100644
index 000000000000..237520fe69ec
--- /dev/null
+++ b/dev-ruby/execjs/execjs-2.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/execjs/execjs-2.3.0.ebuild,v 1.1 2015/02/04 19:58:01 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="ExecJS lets you run JavaScript code from Ruby"
+HOMEPAGE="https://github.com/sstephenson/execjs"
+SRC_URI="https://github.com/sstephenson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+
+IUSE="test"
+
+# execjs supports various javascript runtimes. They are listed in order
+# as per the documentation. For now only include the ones already in the
+# tree.
+
+# therubyracer, therubyrhino, node.js, spidermonkey (deprecated)
+
+# spidermonkey doesn't pass the test suite:
+# https://github.com/sstephenson/execjs/issues/62
+
+RDEPEND+=" || ( net-libs/nodejs )"
+
+all_ruby_prepare() {
+ # Avoid test requiring network connectivity. We could potentially
+ # substitute dev-ruby/coffee-script-source for this.
+ sed -i -e '/test_coffeescript/,/end/ s:^:#:' test/test_execjs.rb || die
+}