summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-06-15 03:29:57 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-06-15 03:29:57 +0000
commitdbae5e7ac249dedf128d484cacf2f9947737f2e3 (patch)
treedf6bf8ee872405a6861c9d4ff493766eda2aa18e /dev-ruby/facter/facter-1.7.4.ebuild
parentremoving another (diff)
downloadgentoo-2-dbae5e7ac249dedf128d484cacf2f9947737f2e3.tar.gz
gentoo-2-dbae5e7ac249dedf128d484cacf2f9947737f2e3.tar.bz2
gentoo-2-dbae5e7ac249dedf128d484cacf2f9947737f2e3.zip
fixes bug 513286 CVE-2014-3248
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-ruby/facter/facter-1.7.4.ebuild')
-rw-r--r--dev-ruby/facter/facter-1.7.4.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-ruby/facter/facter-1.7.4.ebuild b/dev-ruby/facter/facter-1.7.4.ebuild
deleted file mode 100644
index 9da72b0f3f60..000000000000
--- a/dev-ruby/facter/facter-1.7.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/facter-1.7.4.ebuild,v 1.1 2013/12/19 21:21:40 prometheanfire Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 jruby"
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_BINWRAP="facter"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A cross-platform Ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="+dmi +pciutils"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-
-CDEPEND="
- sys-apps/net-tools
- sys-apps/lsb-release
- dmi? ( sys-apps/dmidecode )
- pciutils? ( sys-apps/pciutils )"
-
-RDEPEND+=" ${CDEPEND}"
-DEPEND+=" test? ( ${CDEPEND} )"
-
-#RUBY_PATCHES=( ${P}-fix-proc-self-status.patch )
-
-ruby_add_bdepend "test? ( >=dev-ruby/mocha-0.10.5:0.10 <dev-ruby/rspec-2.14:2 )"
-
-all_ruby_prepare() {
- # Provide explicit path since /sbin is not in the default PATH on
- # Gentoo.
- sed -i -e 's:arp -an:/sbin/arp -an:' lib/facter/util/ec2.rb spec/unit/util/ec2_spec.rb || die
-
- # Ensure the correct version of mocha is used without using bundler.
- sed -i -e '9igem "mocha", "~>0.10.5"' spec/spec_helper.rb || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- # Create the directory for custom facts.
- keepdir /etc/facter/facts.d
-}