summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-09-07 11:28:40 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-09-07 11:28:40 +0000
commitd193f7ee55cccd6334a845a20072a11e84fbcdca (patch)
tree7211cb2e8667452aa87a8df138ede794c2d05091 /dev-ruby/flog
parentVersion bump. (diff)
downloadgentoo-2-d193f7ee55cccd6334a845a20072a11e84fbcdca.tar.gz
gentoo-2-d193f7ee55cccd6334a845a20072a11e84fbcdca.tar.bz2
gentoo-2-d193f7ee55cccd6334a845a20072a11e84fbcdca.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/flog')
-rw-r--r--dev-ruby/flog/ChangeLog7
-rw-r--r--dev-ruby/flog/flog-4.1.2.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-ruby/flog/ChangeLog b/dev-ruby/flog/ChangeLog
index a4deca6f0209..fa6314b1a22e 100644
--- a/dev-ruby/flog/ChangeLog
+++ b/dev-ruby/flog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/flog
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/flog/ChangeLog,v 1.8 2013/09/04 14:14:28 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/flog/ChangeLog,v 1.9 2013/09/07 11:28:40 mrueg Exp $
+
+*flog-4.1.2 (07 Sep 2013)
+
+ 07 Sep 2013; Manuel Rüger <mrueg@gentoo.org> +flog-4.1.2.ebuild:
+ Version bump.
*flog-4.1.1 (04 Sep 2013)
diff --git a/dev-ruby/flog/flog-4.1.2.ebuild b/dev-ruby/flog/flog-4.1.2.ebuild
new file mode 100644
index 000000000000..5cc192b2af3a
--- /dev/null
+++ b/dev-ruby/flog/flog-4.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/flog/flog-4.1.2.ebuild,v 1.1 2013/09/07 11:28:40 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Flog reports the most tortured code in an easy to read pain report."
+HOMEPAGE="http://ruby.sadi.st/"
+LICENSE="MIT"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+ruby_add_rdepend "=dev-ruby/ruby_parser-3* >dev-ruby/ruby_parser-3.1.0
+ =dev-ruby/sexp_processor-4*"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_flog.rb || die
+}