summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2009-01-04 16:32:49 +0000
committerMatti Bickel <mabi@gentoo.org>2009-01-04 16:32:49 +0000
commitff1ee3bf3c4f7220ee4eea2e35d3d26b2a2d24bb (patch)
tree57c9a5ab3a34530ff4cceab427fb5bac720a40fc /dev-ruby/fxruby
parentamd64/x86 stable, bug #253686 (diff)
downloadgentoo-2-ff1ee3bf3c4f7220ee4eea2e35d3d26b2a2d24bb.tar.gz
gentoo-2-ff1ee3bf3c4f7220ee4eea2e35d3d26b2a2d24bb.tar.bz2
gentoo-2-ff1ee3bf3c4f7220ee4eea2e35d3d26b2a2d24bb.zip
fix useflags, stable markings
(Portage version: 2.1.6.4/cvs/Linux 2.6.23-gentoo-r3-20080120 ppc)
Diffstat (limited to 'dev-ruby/fxruby')
-rw-r--r--dev-ruby/fxruby/ChangeLog9
-rw-r--r--dev-ruby/fxruby/fxruby-1.6.18-r1.ebuild73
-rw-r--r--dev-ruby/fxruby/fxruby-1.6.18.ebuild4
3 files changed, 83 insertions, 3 deletions
diff --git a/dev-ruby/fxruby/ChangeLog b/dev-ruby/fxruby/ChangeLog
index 1fa334547497..949d5a740030 100644
--- a/dev-ruby/fxruby/ChangeLog
+++ b/dev-ruby/fxruby/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/fxruby
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.71 2009/01/01 15:47:44 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.72 2009/01/04 16:32:49 mabi Exp $
+
+*fxruby-1.6.18-r1 (04 Jan 2009)
+
+ 04 Jan 2009; Matti Bickel <mabi@gentoo.org> fxruby-1.6.18.ebuild,
+ +fxruby-1.6.18-r1.ebuild:
+ fix doc and example use flag behaviour, revert accidential initial stable
+ version back to ~arch for the next days
01 Jan 2009; Matti Bickel <mabi@gentoo.org> fxruby-1.6.18.ebuild:
fix install failure, general ebuild cleanup thanks to a3li
diff --git a/dev-ruby/fxruby/fxruby-1.6.18-r1.ebuild b/dev-ruby/fxruby/fxruby-1.6.18-r1.ebuild
new file mode 100644
index 000000000000..df84955aee55
--- /dev/null
+++ b/dev-ruby/fxruby/fxruby-1.6.18-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.18-r1.ebuild,v 1.1 2009/01/04 16:32:49 mabi Exp $
+
+RUBY_BUG_145222=yes
+inherit ruby
+
+MY_P="FXRuby-${PV}"
+
+DESCRIPTION="Ruby language binding to the FOX GUI toolkit"
+HOMEPAGE="http://www.fxruby.org/"
+SRC_URI="mirror://rubyforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.6"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples doc"
+
+DEPEND="=x11-libs/fox-1.6*
+ >=x11-libs/fxscintilla-1.62-r1"
+USE_RUBY="ruby18 ruby19"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e 's:libs, "fxscintilla":libs, "fxscintilla-1.6":g' \
+ ext/fox16/extconf.rb || die "sed error"
+ einfo "Avoid -O0 builds"
+ sed -i -e 's:-O0 -Iinclude:-Iinclude:g' \
+ ext/fox16/extconf.rb || die "Can't fix forced -O0"
+}
+
+src_install() {
+ ${RUBY} install.rb config --prefix="${D}/usr" "$@" \
+ ${RUBY_ECONF} || die "install.rb config failed"
+
+ ${RUBY} install.rb install "$@" --prefix="${D}" \
+ ${RUBY_ECONF} || die "install.rb install failed"
+
+ # from ruby.eclass, but with use flag control
+ if use doc; then
+ local rdbase=/usr/share/doc/${PF}/rd rdfiles=$(find . -name '*.rd*')
+
+ einfo "running dodoc for ruby ;)"
+
+ insinto ${rdbase}
+ [ -n "${rdfiles}" ] && doins ${rdfiles}
+ rmdir ${D}${rdbase} 2>/dev/null || true
+ if [ -d doc -o -d docs ] ; then
+ dohtml -x html -r {doc,docs}/*
+ dohtml -r {doc,docs}/html/*
+ else
+ dohtml -r *
+ fi
+
+ for i in ChangeLog* [[:upper:]][[:upper:]]* ; do
+ [ -e $i ] && dodoc $i
+ done
+ fi
+
+ if use examples; then
+ for dir in sample samples example examples; do
+ if [ -d ${dir} ] ; then
+ dodir /usr/share/doc/${PF}
+ cp -pPR ${dir} ${D}/usr/share/doc/${PF} || die "cp failed"
+ fi
+ done
+ fi
+}
+
diff --git a/dev-ruby/fxruby/fxruby-1.6.18.ebuild b/dev-ruby/fxruby/fxruby-1.6.18.ebuild
index f987e6a6c942..3ab99dd10460 100644
--- a/dev-ruby/fxruby/fxruby-1.6.18.ebuild
+++ b/dev-ruby/fxruby/fxruby-1.6.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.18.ebuild,v 1.3 2009/01/02 04:41:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.18.ebuild,v 1.4 2009/01/04 16:32:49 mabi Exp $
RUBY_BUG_145222=yes
inherit ruby
@@ -13,7 +13,7 @@ SRC_URI="mirror://rubyforge/${PN}/${MY_P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="1.6"
-KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="examples doc"
DEPEND="=x11-libs/fox-1.6*