summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-05-15 00:51:50 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-05-15 00:51:50 +0000
commit42e8ccc092ee0be30fb513780cc50b212b82388b (patch)
tree19141a2a824f6b50e7e71af746c3bc13a1dfbce4 /dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild
parentRemove ruby18. (diff)
downloadgentoo-2-42e8ccc092ee0be30fb513780cc50b212b82388b.tar.gz
gentoo-2-42e8ccc092ee0be30fb513780cc50b212b82388b.tar.bz2
gentoo-2-42e8ccc092ee0be30fb513780cc50b212b82388b.zip
Add ruby21 target. Remove ruby18.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild')
-rw-r--r--dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild b/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild
new file mode 100644
index 000000000000..81c9f70c7434
--- /dev/null
+++ b/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/gnuplot-2.6.2-r2.ebuild,v 1.1 2014/05/15 00:51:50 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS.txt ChangeLog README.textile"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Gnuplot drawing library - Ruby Bindings"
+HOMEPAGE="http://rgplot.rubyforge.org/"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+SLOT="0"
+
+RDEPEND+=" sci-visualization/gnuplot"
+
+all_ruby_prepare() {
+ # Existing metadata causes a crash in jruby, so use our own.
+ rm ../metadata || die "Unable to remove metadata."
+}
+
+each_ruby_test() {
+ ${RUBY} -Ctest test_gnuplot.rb || die
+}