summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-18 13:32:21 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-18 13:32:21 +0000
commit58960503b4805be42c03d6f401693bd2972f3779 (patch)
treee01f24ff3eefc9120f7bc757a7410826bad1644c /dev-ruby/hoe
parentusemask libv4l, linux only (diff)
downloadgentoo-2-58960503b4805be42c03d6f401693bd2972f3779.tar.gz
gentoo-2-58960503b4805be42c03d6f401693bd2972f3779.tar.bz2
gentoo-2-58960503b4805be42c03d6f401693bd2972f3779.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/hoe')
-rw-r--r--dev-ruby/hoe/ChangeLog7
-rw-r--r--dev-ruby/hoe/hoe-2.12.4.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ruby/hoe/ChangeLog b/dev-ruby/hoe/ChangeLog
index d0d3b27751f8..19dbb7e04335 100644
--- a/dev-ruby/hoe/ChangeLog
+++ b/dev-ruby/hoe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hoe
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.124 2011/11/10 11:56:55 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.125 2011/12/18 13:32:21 graaff Exp $
+
+*hoe-2.12.4 (18 Dec 2011)
+
+ 18 Dec 2011; Hans de Graaff <graaff@gentoo.org> +hoe-2.12.4.ebuild:
+ Version bump.
10 Nov 2011; Naohiro Aota <naota@gentoo.org> hoe-2.12.3.ebuild:
Add ~x86-fbsd
diff --git a/dev-ruby/hoe/hoe-2.12.4.ebuild b/dev-ruby/hoe/hoe-2.12.4.ebuild
new file mode 100644
index 000000000000..fa08bb89a9d4
--- /dev/null
+++ b/dev-ruby/hoe/hoe-2.12.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-2.12.4.ebuild,v 1.1 2011/12/18 13:32:21 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation."
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+# - also requires dev-ruby/hoe-seattlerb for 1.9;
+# - dev-ruby/gemcutter is an optional dependency at both runtime and
+# test-time, at least for us;
+# - rubyforge is loaded at runtime when needed, so we don't strictly
+# depend on it at runtime, but we need it for tests (for now);
+ruby_add_bdepend "test? ( dev-ruby/minitest >=dev-ruby/rubyforge-2.0.4 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7"
+
+all_ruby_prepare() {
+ # Make test regexp more lenient to cover the way we name the binaries.
+ sed -i -e 's/sudo gem/sudo .?gem/' -e 's/\^gem/^.?gem/' test/test_hoe.rb || die
+}