summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-04-18 14:24:05 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-04-18 14:24:05 +0000
commitc4d6e61a111f0f2ba95b69dcbb7b3a046b2ec377 (patch)
treef77f41466579fa4c53d0b49770705e7d87887160 /dev-ruby/hoe
parentVersion bump. (diff)
downloadgentoo-2-c4d6e61a111f0f2ba95b69dcbb7b3a046b2ec377.tar.gz
gentoo-2-c4d6e61a111f0f2ba95b69dcbb7b3a046b2ec377.tar.bz2
gentoo-2-c4d6e61a111f0f2ba95b69dcbb7b3a046b2ec377.zip
Move ruby21 target to -r1. Add missing die statement.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/hoe')
-rw-r--r--dev-ruby/hoe/ChangeLog8
-rw-r--r--dev-ruby/hoe/hoe-3.9.0-r1.ebuild41
-rw-r--r--dev-ruby/hoe/hoe-3.9.0.ebuild6
3 files changed, 51 insertions, 4 deletions
diff --git a/dev-ruby/hoe/ChangeLog b/dev-ruby/hoe/ChangeLog
index 3fda9ee99fc7..a4402b0955f9 100644
--- a/dev-ruby/hoe/ChangeLog
+++ b/dev-ruby/hoe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/hoe
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.152 2014/04/05 23:32:10 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.153 2014/04/18 14:24:05 mrueg Exp $
+
+*hoe-3.9.0-r1 (18 Apr 2014)
+
+ 18 Apr 2014; Manuel Rüger <mrueg@gentoo.org> +hoe-3.9.0-r1.ebuild,
+ hoe-3.9.0.ebuild:
+ Move ruby21 target to -r1. Add missing die statement.
05 Apr 2014; Manuel Rüger <mrueg@gentoo.org> hoe-2.12.5.ebuild,
hoe-2.13.0-r1.ebuild, hoe-3.9.0.ebuild:
diff --git a/dev-ruby/hoe/hoe-3.9.0-r1.ebuild b/dev-ruby/hoe/hoe-3.9.0-r1.ebuild
new file mode 100644
index 000000000000..96e5b7aea66e
--- /dev/null
+++ b/dev-ruby/hoe/hoe-3.9.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-3.9.0-r1.ebuild,v 1.1 2014/04/18 14:24:05 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation."
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7 >=dev-ruby/rdoc-3.10"
+
+all_ruby_prepare() {
+ # Skip isolation
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+
+ # Skip test depending on specifics of gem command name
+ sed -i -e '/test_nosudo/,/^ end/ s:^:#:' test/test_hoe.rb || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ rdoc --title "seattlerb's hoe-3.5.1 Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt || die
+}
diff --git a/dev-ruby/hoe/hoe-3.9.0.ebuild b/dev-ruby/hoe/hoe-3.9.0.ebuild
index 306a8451ccf3..e5bb00af15c0 100644
--- a/dev-ruby/hoe/hoe-3.9.0.ebuild
+++ b/dev-ruby/hoe/hoe-3.9.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-3.9.0.ebuild,v 1.3 2014/04/05 23:32:10 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-3.9.0.ebuild,v 1.4 2014/04/18 14:24:05 mrueg Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 jruby"
+USE_RUBY="ruby19 ruby20 jruby"
RUBY_FAKEGEM_TASK_DOC=""
@@ -37,5 +37,5 @@ all_ruby_prepare() {
all_ruby_compile() {
all_fakegem_compile
- rdoc --title "seattlerb's hoe-3.5.1 Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt
+ rdoc --title "seattlerb's hoe-3.5.1 Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt || die
}