summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-16 12:20:44 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-16 12:20:44 +0000
commit89c5374ab900bd104c6271b3f68b2af14ec0fee5 (patch)
tree64e09cbea6bc421e11df58f39673d22335cf382b /dev-ruby/i18n
parentMask some packages for treecleaning. (diff)
downloadgentoo-2-89c5374ab900bd104c6271b3f68b2af14ec0fee5.tar.gz
gentoo-2-89c5374ab900bd104c6271b3f68b2af14ec0fee5.tar.bz2
gentoo-2-89c5374ab900bd104c6271b3f68b2af14ec0fee5.zip
Drop masked versions.
(Portage version: 2.1.11.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/i18n')
-rw-r--r--dev-ruby/i18n/ChangeLog6
-rw-r--r--dev-ruby/i18n/files/i18n-0.3.7-gentoo.patch32
-rw-r--r--dev-ruby/i18n/i18n-0.1.3.ebuild40
-rw-r--r--dev-ruby/i18n/i18n-0.3.7.ebuild69
4 files changed, 5 insertions, 142 deletions
diff --git a/dev-ruby/i18n/ChangeLog b/dev-ruby/i18n/ChangeLog
index 9ef72369ef28..d8d90ed2fcee 100644
--- a/dev-ruby/i18n/ChangeLog
+++ b/dev-ruby/i18n/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/i18n
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.48 2012/08/16 03:58:55 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.49 2012/09/16 12:20:44 pacho Exp $
+
+ 16 Sep 2012; Pacho Ramos <pacho@gentoo.org> -files/i18n-0.3.7-gentoo.patch,
+ -i18n-0.1.3.ebuild, -i18n-0.3.7.ebuild:
+ Drop masked versions.
16 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> i18n-0.3.7.ebuild,
i18n-0.4.2.ebuild, i18n-0.5.0-r1.ebuild, i18n-0.6.0-r1.ebuild:
diff --git a/dev-ruby/i18n/files/i18n-0.3.7-gentoo.patch b/dev-ruby/i18n/files/i18n-0.3.7-gentoo.patch
deleted file mode 100644
index 17fd05bf7430..000000000000
--- a/dev-ruby/i18n/files/i18n-0.3.7-gentoo.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/test/backend/interpolation_compiler_test.rb b/test/backend/interpolation_compiler_test.rb
-index 5051299..5852b9c 100644
---- a/test/backend/interpolation_compiler_test.rb
-+++ b/test/backend/interpolation_compiler_test.rb
-@@ -104,5 +104,5 @@ class I18nBackendInterpolationCompilerTest < Test::Unit::TestCase
- end
-
- # I kinda don't think this really is a correct behavior
-- undef :'test interpolation: given no values it does not alter the string'
--end
-\ No newline at end of file
-+ undef_method 'test interpolation: given no values it does not alter the string'
-+end
-diff --git a/test/test_setup_requirements.rb b/test/test_setup_requirements.rb
-index d5a2cbe..a057042 100644
---- a/test/test_setup_requirements.rb
-+++ b/test/test_setup_requirements.rb
-@@ -34,6 +34,7 @@ end
-
- def setup_active_record
- begin
-+ require 'sqlite3'
- require 'active_record'
- ActiveRecord::Base.connection
- true
-@@ -63,4 +64,4 @@ def connect_active_record
- t.boolean :is_proc, :default => false
- end
- end
--end
-\ No newline at end of file
-+end
diff --git a/dev-ruby/i18n/i18n-0.1.3.ebuild b/dev-ruby/i18n/i18n-0.1.3.ebuild
deleted file mode 100644
index 1c4faf98d324..000000000000
--- a/dev-ruby/i18n/i18n-0.1.3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.1.3.ebuild,v 1.10 2012/05/01 18:24:12 armin76 Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="README.textile"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Add Internationalization support to your Ruby application."
-HOMEPAGE="http://rails-i18n.org/"
-
-# We have a valid expectance that *this* is the correct tarball for
-# version 0.1.3, unfortunately there is *no such official release* as
-# the one bundled with activesupport. On the other hand, this seems to
-# be it, minus some test changes.
-SRC_URI="http://github.com/svenfuchs/i18n/tarball/38d85ea3b8eec032c1b0898a30f8010917416d9d -> ${PN}-git-${PV}.tgz"
-S="${WORKDIR}/svenfuchs-${PN}-38d85ea"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend test "dev-ruby/mocha dev-ruby/activesupport"
-
-src_prepare() {
- ruby-ng_src_prepare
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
-}
-
-src_test() {
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
- ruby-ng_src_test
-}
diff --git a/dev-ruby/i18n/i18n-0.3.7.ebuild b/dev-ruby/i18n/i18n-0.3.7.ebuild
deleted file mode 100644
index 1a2bb4dcb59e..000000000000
--- a/dev-ruby/i18n/i18n-0.3.7.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.3.7.ebuild,v 1.8 2012/08/16 03:58:55 flameeyes Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 jruby ree18"
-
-# doc regeneration seem to need Jeweler, which is not currently
-# available
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="README.textile CHANGELOG.textile"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Add Internationalization support to your Ruby application."
-HOMEPAGE="http://rails-i18n.org/"
-
-SRC_URI="http://github.com/svenfuchs/${PN}/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
-S="${WORKDIR}/svenfuchs-${PN}-*"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-# Optionally, the testsuite uses the activerecord gem to run some
-# tests; whent hey run, they require sqlite3-ruby, and that is not
-# available on JRuby.
-USE_RUBY="${USE_RUBY/jruby/}" \
- ruby_add_bdepend "
- test? (
- dev-ruby/activerecord
- dev-ruby/sqlite3
- dev-ruby/ruby2ruby
- )"
-
-# mocha is optionally used by the testsuite, try to increase coverage
-# of testing by depending on it; when mocha is used, though,
-# test-unit:2 cannot be merged at the same time (mocha problem?)
-#
-# One further test dependency would be ruby-cldr
-# (http://rubygems.org/gems/ruby-cldr) but we don't have it in tree
-# yet.
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha
- !!dev-ruby/test-unit:2
- )"
-
-src_compile() {
- # permissions need to be stricter for Ruby-Inline to work properly.
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
- ruby-ng_src_compile
-}
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
-
-src_test() {
- # permissions need to be stricter for Ruby-Inline to work properly.
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
- ruby-ng_src_test
-}