summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-30 06:32:14 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-30 06:32:14 +0000
commitc0e20deac15bd283566432668778ace92b1ed416 (patch)
tree624f04c2d74e88bfc3a2004d2c68249109aa99ae /dev-ruby/jruby-openssl
parentControl libv4l dep via USE=v4l #364817 by Samuli Suominen. (diff)
downloadgentoo-2-c0e20deac15bd283566432668778ace92b1ed416.tar.gz
gentoo-2-c0e20deac15bd283566432668778ace92b1ed416.tar.bz2
gentoo-2-c0e20deac15bd283566432668778ace92b1ed416.zip
Version bump. Depend on bouncy-castle-java to allow tests to run. Drop x86 keyword due to this, bug 365379.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/jruby-openssl')
-rw-r--r--dev-ruby/jruby-openssl/ChangeLog11
-rw-r--r--dev-ruby/jruby-openssl/jruby-openssl-0.7.4.ebuild30
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-ruby/jruby-openssl/ChangeLog b/dev-ruby/jruby-openssl/ChangeLog
index 4da579d3525a..3c494e71d506 100644
--- a/dev-ruby/jruby-openssl/ChangeLog
+++ b/dev-ruby/jruby-openssl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/jruby-openssl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jruby-openssl/ChangeLog,v 1.9 2010/11/26 12:22:09 graaff Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jruby-openssl/ChangeLog,v 1.10 2011/04/30 06:32:14 graaff Exp $
+
+*jruby-openssl-0.7.4 (30 Apr 2011)
+
+ 30 Apr 2011; Hans de Graaff <graaff@gentoo.org>
+ +jruby-openssl-0.7.4.ebuild:
+ Version bump. Depend on bouncy-castle-java to allow tests to run. Drop x86
+ keyword due to this, bug 365379.
*jruby-openssl-0.7.2 (26 Nov 2010)
diff --git a/dev-ruby/jruby-openssl/jruby-openssl-0.7.4.ebuild b/dev-ruby/jruby-openssl/jruby-openssl-0.7.4.ebuild
new file mode 100644
index 000000000000..74dc259107fc
--- /dev/null
+++ b/dev-ruby/jruby-openssl/jruby-openssl-0.7.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/jruby-openssl/jruby-openssl-0.7.4.ebuild,v 1.1 2011/04/30 06:32:14 graaff Exp $
+
+EAPI=2
+
+USE_RUBY=jruby
+
+RUBY_FAKEGEM_TASK_DOC="redocs"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby SSL library that works with JRuby"
+HOMEPAGE="http://rubyforge.org/projects/jruby-extras"
+
+LICENSE="MIT || ( CPL-1.0 GPL-2 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/hoe )"
+ruby_add_bdepend "test? ( dev-ruby/hoe dev-ruby/mocha )"
+
+ruby_add_rdepend ">=dev-ruby/bouncy-castle-java-1.5.0146.1"
+
+all_ruby_prepare() {
+ # Remove a test that only works with JCE installed.
+ sed -i -e 's/OpenSSL::OPENSSL_VERSION_NUMBER > 0x00907000/false/' test/openssl/test_cipher.rb || die
+}