summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-26 05:55:07 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-26 05:55:07 +0000
commit9d2008861d4cb5eb77a347a34e94e703ee353b81 (patch)
tree042793e0b4232f8c213a9d24c19b57a4c0019405 /dev-ruby/json
parentadding oslo-vmware to 2014.1.9999 (diff)
downloadgentoo-2-9d2008861d4cb5eb77a347a34e94e703ee353b81.tar.gz
gentoo-2-9d2008861d4cb5eb77a347a34e94e703ee353b81.tar.bz2
gentoo-2-9d2008861d4cb5eb77a347a34e94e703ee353b81.zip
Add back json-1.7.7 because app-admin/chef has dependencies that violate our policy but also no maintainer, bug 484348.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/ChangeLog6
-rw-r--r--dev-ruby/json/json-1.7.7.ebuild65
-rw-r--r--dev-ruby/json/json-1.8.1.ebuild4
3 files changed, 72 insertions, 3 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index b94e3bb97776..df128ddec282 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.146 2014/07/25 13:35:15 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.147 2014/07/26 05:55:07 graaff Exp $
+
+ 26 Jul 2014; Hans de Graaff <graaff@gentoo.org> +json-1.7.7.ebuild:
+ Add back json-1.7.7 because app-admin/chef has dependencies that violate our
+ policy but also no maintainer, bug 484348.
25 Jul 2014; Manuel Rüger <mrueg@gentoo.org> -json-1.7.7-r1.ebuild,
-json-1.7.7.ebuild:
diff --git a/dev-ruby/json/json-1.7.7.ebuild b/dev-ruby/json/json-1.7.7.ebuild
new file mode 100644
index 000000000000..e7a840bc3eaa
--- /dev/null
+++ b/dev-ruby/json/json-1.7.7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.7.7.ebuild,v 1.16 2014/07/26 05:55:07 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README.rdoc README-json-jruby.markdown"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="json.gemspec"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A JSON implementation as a Ruby extension."
+HOMEPAGE="http://json.rubyforge.org/"
+LICENSE="|| ( Ruby GPL-2 )"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND}"
+DEPEND="${DEPEND}
+ dev-util/ragel"
+
+ruby_add_bdepend "dev-ruby/rake"
+
+all_ruby_prepare() {
+ # Avoid building the extension twice!
+ # And use rdoc instead of sdoc which we don't have packaged
+ # And don't call git to list files. We're using the pregenerated spec anyway.
+ sed -i \
+ -e 's| => :compile||' \
+ -e 's| => :clean||' \
+ -e 's|sdoc|rdoc|' \
+ -e 's|`git ls-files`|""|' \
+ Rakefile || die "rakefile fix failed"
+}
+
+each_ruby_compile() {
+ # Since 1.5.0 a Java extension is provided but it does not compile.
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ${RUBY} -S rake compile || die "extension compile failed"
+ fi
+}
+
+each_ruby_test() {
+ JSON=pure \
+ ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "pure ruby tests failed"
+
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ JSON=ext \
+ ${RUBY} -Iext:lib -S testrb tests/test_*.rb || die "ext ruby tests failed"
+ fi
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ if [[ $(basename ${RUBY}) != "jruby" ]]; then
+ ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
+ ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
+ fi
+}
diff --git a/dev-ruby/json/json-1.8.1.ebuild b/dev-ruby/json/json-1.8.1.ebuild
index 6542b6f41ee1..630ef4a6d3fa 100644
--- a/dev-ruby/json/json-1.8.1.ebuild
+++ b/dev-ruby/json/json-1.8.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.8.1.ebuild,v 1.3 2014/04/05 23:40:47 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.8.1.ebuild,v 1.4 2014/07/26 05:55:07 graaff Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21 jruby"
+USE_RUBY="ruby19 ruby20 ruby21 jruby rbx"
RUBY_FAKEGEM_TASK_DOC="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README.rdoc README-json-jruby.markdown"