summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 13:36:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-22 13:36:28 +0000
commite4722125f0abf0cab061384baced79228d216f55 (patch)
treea735f54c7d193ebbffa37cfacb9a0c1a1d764771 /dev-ruby/json
parentRevision bump so that ruby19 can be dropped for upcoming stabilization. (diff)
downloadgentoo-2-e4722125f0abf0cab061384baced79228d216f55.tar.gz
gentoo-2-e4722125f0abf0cab061384baced79228d216f55.tar.bz2
gentoo-2-e4722125f0abf0cab061384baced79228d216f55.zip
Cleanup old versions, use new syntax.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/ChangeLog7
-rw-r--r--dev-ruby/json/json-1.2.0.ebuild15
-rw-r--r--dev-ruby/json/json-1.2.2.ebuild11
-rw-r--r--dev-ruby/json/json-1.2.3.ebuild64
-rw-r--r--dev-ruby/json/json-1.2.4.ebuild64
-rw-r--r--dev-ruby/json/json-1.4.2.ebuild64
-rw-r--r--dev-ruby/json/json-1.4.3.ebuild11
7 files changed, 18 insertions, 218 deletions
diff --git a/dev-ruby/json/ChangeLog b/dev-ruby/json/ChangeLog
index 9ec4ec8b06d7..38a23046730e 100644
--- a/dev-ruby/json/ChangeLog
+++ b/dev-ruby/json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/json
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.28 2010/05/19 19:48:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/ChangeLog,v 1.29 2010/05/22 13:36:28 flameeyes Exp $
+
+ 22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org> -json-1.2.0.ebuild,
+ json-1.2.2.ebuild, -json-1.2.3.ebuild, -json-1.2.4.ebuild,
+ -json-1.4.2.ebuild, json-1.4.3.ebuild:
+ Cleanup old versions, use new syntax.
19 May 2010; Raúl Porcel <armin76@gentoo.org> json-1.2.2.ebuild:
ia64/sparc stable wrt #316883
diff --git a/dev-ruby/json/json-1.2.0.ebuild b/dev-ruby/json/json-1.2.0.ebuild
deleted file mode 100644
index 1bf3a31aeaf3..000000000000
--- a/dev-ruby/json/json-1.2.0.ebuild
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.2.0.ebuild,v 1.1 2009/12/04 07:37:52 graaff Exp $
-
-inherit gems
-
-USE_RUBY="ruby18"
-
-DESCRIPTION="A JSON implementation as a Ruby extension."
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-
-KEYWORDS="~amd64 ~ppc ~x86"
-SLOT="0"
-IUSE=""
diff --git a/dev-ruby/json/json-1.2.2.ebuild b/dev-ruby/json/json-1.2.2.ebuild
index 2c10dc658310..c92dd8633310 100644
--- a/dev-ruby/json/json-1.2.2.ebuild
+++ b/dev-ruby/json/json-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.2.2.ebuild,v 1.4 2010/05/19 19:48:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.2.2.ebuild,v 1.5 2010/05/22 13:36:28 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18"
@@ -20,11 +20,12 @@ KEYWORDS="~amd64 ~hppa ia64 ~ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-s
SLOT="0"
IUSE=""
-RDEPEND=""
-DEPEND="dev-util/ragel"
+RDEPEND="${RDEPEND}"
+DEPEND="${DEPEND}
+ dev-util/ragel"
-ruby_add_bdepend test virtual/ruby-test-unit
-ruby_add_bdepend dev-ruby/rake
+ruby_add_bdepend "dev-ruby/rake
+ test? ( virtual/ruby-test-unit )"
all_ruby_prepare() {
# Avoid building the extension twice!
diff --git a/dev-ruby/json/json-1.2.3.ebuild b/dev-ruby/json/json-1.2.3.ebuild
deleted file mode 100644
index 3b3fdfd96850..000000000000
--- a/dev-ruby/json/json-1.2.3.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.2.3.ebuild,v 1.1 2010/04/04 06:54:38 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension."
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-SRC_URI="mirror://rubygems/${P}.gem"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND=""
-DEPEND="dev-util/ragel"
-
-ruby_add_bdepend test virtual/ruby-test-unit
-ruby_add_bdepend dev-ruby/rake
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- sed -i \
- -e 's| => :compile_ext||' \
- -e 's| => :clean||' \
- Rakefile || die "rakefile fix failed"
-}
-
-each_ruby_compile() {
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ${RUBY} -S rake compile_ext || die "extension compile failed"
- fi
-}
-
-each_ruby_test() {
- # We have to set RUBYLIB because otherwise the tests will run
- # against the sytem-installed json; at the same time, we cannot
- # use the -I parameter because rake won't let it pass to the
- # testrb call that is executed down the road.
-
- RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
- ${RUBY} -S rake test_pure || die "pure ruby tests failed"
-
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
- ${RUBY} -Ilib:ext/json/ext -S rake test_ext || die " ruby extension tests failed"
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ruby_fakegem_newins ext/json/ext/generator.so lib/json/generator.so
- ruby_fakegem_newins ext/json/ext/parser.so lib/json/parser.so
- fi
-}
diff --git a/dev-ruby/json/json-1.2.4.ebuild b/dev-ruby/json/json-1.2.4.ebuild
deleted file mode 100644
index 6de72cf9cc5f..000000000000
--- a/dev-ruby/json/json-1.2.4.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.2.4.ebuild,v 1.1 2010/04/11 06:54:26 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension."
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-SRC_URI="mirror://rubygems/${P}.gem"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND=""
-DEPEND="dev-util/ragel"
-
-ruby_add_bdepend test virtual/ruby-test-unit
-ruby_add_bdepend dev-ruby/rake
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- sed -i \
- -e 's| => :compile_ext||' \
- -e 's| => :clean||' \
- Rakefile || die "rakefile fix failed"
-}
-
-each_ruby_compile() {
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ${RUBY} -S rake compile_ext || die "extension compile failed"
- fi
-}
-
-each_ruby_test() {
- # We have to set RUBYLIB because otherwise the tests will run
- # against the sytem-installed json; at the same time, we cannot
- # use the -I parameter because rake won't let it pass to the
- # testrb call that is executed down the road.
-
- RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
- ${RUBY} -S rake test_pure || die "pure ruby tests failed"
-
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
- ${RUBY} -Ilib:ext/json/ext -S rake test_ext || die " ruby extension tests failed"
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ruby_fakegem_newins ext/json/ext/generator.so lib/json/generator.so
- ruby_fakegem_newins ext/json/ext/parser.so lib/json/parser.so
- fi
-}
diff --git a/dev-ruby/json/json-1.4.2.ebuild b/dev-ruby/json/json-1.4.2.ebuild
deleted file mode 100644
index 3d161e4783dc..000000000000
--- a/dev-ruby/json/json-1.4.2.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.4.2.ebuild,v 1.1 2010/04/30 08:30:03 graaff Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension."
-HOMEPAGE="http://json.rubyforge.org/"
-LICENSE="|| ( Ruby GPL-2 )"
-SRC_URI="mirror://rubygems/${P}.gem"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND=""
-DEPEND="dev-util/ragel"
-
-ruby_add_bdepend test virtual/ruby-test-unit
-ruby_add_bdepend dev-ruby/rake
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- sed -i \
- -e 's| => :compile_ext||' \
- -e 's| => :clean||' \
- Rakefile || die "rakefile fix failed"
-}
-
-each_ruby_compile() {
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ${RUBY} -S rake compile_ext || die "extension compile failed"
- fi
-}
-
-each_ruby_test() {
- # We have to set RUBYLIB because otherwise the tests will run
- # against the sytem-installed json; at the same time, we cannot
- # use the -I parameter because rake won't let it pass to the
- # testrb call that is executed down the road.
-
- RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
- ${RUBY} -S rake test_pure || die "pure ruby tests failed"
-
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- RUBYLIB="${RUBYLIB}${RUBYLIB+:}lib:ext/json/ext" \
- ${RUBY} -Ilib:ext/json/ext -S rake test_ext || die " ruby extension tests failed"
- fi
-}
-
-each_ruby_install() {
- each_fakegem_install
- if [[ $(basename ${RUBY}) != "jruby" ]]; then
- ruby_fakegem_newins ext/json/ext/generator.so lib/json/generator.so
- ruby_fakegem_newins ext/json/ext/parser.so lib/json/parser.so
- fi
-}
diff --git a/dev-ruby/json/json-1.4.3.ebuild b/dev-ruby/json/json-1.4.3.ebuild
index 07a35439a116..377adf5f701e 100644
--- a/dev-ruby/json/json-1.4.3.ebuild
+++ b/dev-ruby/json/json-1.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.4.3.ebuild,v 1.1 2010/05/07 05:43:53 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/json/json-1.4.3.ebuild,v 1.2 2010/05/22 13:36:28 flameeyes Exp $
EAPI=2
USE_RUBY="ruby18 ruby19 jruby"
@@ -20,11 +20,12 @@ KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x8
SLOT="0"
IUSE=""
-RDEPEND=""
-DEPEND="dev-util/ragel"
+RDEPEND="${RDEPEND}"
+DEPEND="${DEPEND}
+ dev-util/ragel"
-ruby_add_bdepend test virtual/ruby-test-unit
-ruby_add_bdepend dev-ruby/rake
+ruby_add_bdepend "dev-ruby/rake
+ test? ( virtual/ruby-test-unit )"
all_ruby_prepare() {
# Avoid building the extension twice!