summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-14 06:33:40 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-14 06:33:40 +0000
commit1f827bdef46f90e498933b88a04a2abf6d74cade (patch)
tree146b2354cb81dc64b1c0af1df07d484480640e2b /dev-ruby/locale/locale-2.0.8.ebuild
parentRemove old. (diff)
downloadgentoo-2-1f827bdef46f90e498933b88a04a2abf6d74cade.tar.gz
gentoo-2-1f827bdef46f90e498933b88a04a2abf6d74cade.tar.bz2
gentoo-2-1f827bdef46f90e498933b88a04a2abf6d74cade.zip
Version bump.
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/locale/locale-2.0.8.ebuild')
-rw-r--r--dev-ruby/locale/locale-2.0.8.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/locale/locale-2.0.8.ebuild b/dev-ruby/locale/locale-2.0.8.ebuild
new file mode 100644
index 000000000000..bd8a60a7ee2f
--- /dev/null
+++ b/dev-ruby/locale/locale-2.0.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/locale/locale-2.0.8.ebuild,v 1.1 2013/03/14 06:33:40 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19 jruby ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc/reference"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.rdoc doc/text/news.md"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby library which provides basic APIs for localization."
+HOMEPAGE="https://github.com/ruby-gettext/locale"
+LICENSE="|| ( Ruby GPL-2 )"
+SRC_URI="https://github.com/ruby-gettext/locale/archive/${PV}.tar.gz -> ${P}-git.tgz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-macos"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/test-unit-rr )"
+
+all_ruby_prepare() {
+ sed -i -e '/notify/ s:^:#:' test/run-test.rb || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ yard || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples || die
+}