summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-05-31 16:05:49 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-05-31 16:05:49 +0000
commita7d8182e692ec1f3126db7fa603f865f6b30f093 (patch)
tree7bb1151c97b4bfc0971fc0432f0d7656bb895332 /dev-ruby/minitest
parentlibunwind is rather core for our C++ stack. Better not have it link to liblzm... (diff)
downloadgentoo-2-a7d8182e692ec1f3126db7fa603f865f6b30f093.tar.gz
gentoo-2-a7d8182e692ec1f3126db7fa603f865f6b30f093.tar.bz2
gentoo-2-a7d8182e692ec1f3126db7fa603f865f6b30f093.zip
Version bump, drop support for jruby for now.
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'dev-ruby/minitest')
-rw-r--r--dev-ruby/minitest/ChangeLog7
-rw-r--r--dev-ruby/minitest/minitest-5.0.3.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/minitest/ChangeLog b/dev-ruby/minitest/ChangeLog
index f8a269ea08b2..3ffd52e1a50f 100644
--- a/dev-ruby/minitest/ChangeLog
+++ b/dev-ruby/minitest/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/minitest
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.111 2013/05/07 05:24:26 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/ChangeLog,v 1.112 2013/05/31 16:05:49 flameeyes Exp $
+
+*minitest-5.0.3 (31 May 2013)
+
+ 31 May 2013; Diego E. Pettenò <flameeyes@gentoo.org> +minitest-5.0.3.ebuild:
+ Version bump, drop support for jruby for now.
*minitest-4.7.4 (07 May 2013)
diff --git a/dev-ruby/minitest/minitest-5.0.3.ebuild b/dev-ruby/minitest/minitest-5.0.3.ebuild
new file mode 100644
index 000000000000..bdfd17b5c296
--- /dev/null
+++ b/dev-ruby/minitest/minitest-5.0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/minitest/minitest-5.0.3.ebuild,v 1.1 2013/05/31 16:05:49 flameeyes Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+# Rake is the easiest way to go through this unfortunately.
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="minitest/unit is a small and fast replacement for ruby's huge and slow test/unit."
+HOMEPAGE="https://github.com/seattlerb/minitest"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/hoe dev-ruby/rdoc )
+ ruby_targets_ruby18? ( !!dev-ruby/minitest[ruby_targets_ruby18] )"
+
+# There is a nasty bug that tests fail if minitest is loaded already
+# from the system.