summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-12 20:43:50 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-05-12 20:43:50 +0000
commit18cd917aba8baabbfb71f3848d9f8be9e812c982 (patch)
treeff7f3d9c5c3bc0d724deeb459777861498174395 /dev-ruby/mongoid
parentunmask pambase[consolekit] (diff)
downloadgentoo-2-18cd917aba8baabbfb71f3848d9f8be9e812c982.tar.gz
gentoo-2-18cd917aba8baabbfb71f3848d9f8be9e812c982.tar.bz2
gentoo-2-18cd917aba8baabbfb71f3848d9f8be9e812c982.zip
Version bump; remove old.
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/mongoid')
-rw-r--r--dev-ruby/mongoid/ChangeLog9
-rw-r--r--dev-ruby/mongoid/mongoid-2.4.10.ebuild (renamed from dev-ruby/mongoid/mongoid-2.4.6.ebuild)4
-rw-r--r--dev-ruby/mongoid/mongoid-2.4.4.ebuild75
-rw-r--r--dev-ruby/mongoid/mongoid-2.4.5.ebuild77
-rw-r--r--dev-ruby/mongoid/mongoid-2.4.7.ebuild77
5 files changed, 10 insertions, 232 deletions
diff --git a/dev-ruby/mongoid/ChangeLog b/dev-ruby/mongoid/ChangeLog
index 809ff1c5f402..da236d0707e5 100644
--- a/dev-ruby/mongoid/ChangeLog
+++ b/dev-ruby/mongoid/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/mongoid
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongoid/ChangeLog,v 1.11 2012/05/11 04:14:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongoid/ChangeLog,v 1.12 2012/05/12 20:43:50 flameeyes Exp $
+
+*mongoid-2.4.10 (12 May 2012)
+
+ 12 May 2012; Diego E. Pettenò <flameeyes@gentoo.org> +mongoid-2.4.10.ebuild,
+ -mongoid-2.4.4.ebuild, -mongoid-2.4.5.ebuild, -mongoid-2.4.6.ebuild,
+ -mongoid-2.4.7.ebuild:
+ Version bump; remove old.
11 May 2012; Diego E. Pettenò <flameeyes@gentoo.org> mongoid-2.4.9.ebuild:
Add support for ruby 1.9 (works fine).
diff --git a/dev-ruby/mongoid/mongoid-2.4.6.ebuild b/dev-ruby/mongoid/mongoid-2.4.10.ebuild
index 068a5e80bc09..84057b90a2da 100644
--- a/dev-ruby/mongoid/mongoid-2.4.6.ebuild
+++ b/dev-ruby/mongoid/mongoid-2.4.10.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongoid/mongoid-2.4.6.ebuild,v 1.1 2012/03/08 01:56:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongoid/mongoid-2.4.10.ebuild,v 1.1 2012/05/12 20:43:50 flameeyes Exp $
EAPI=4
-USE_RUBY="ruby18"
+USE_RUBY="ruby18 ruby19"
#RUBY_FAKEGEM_TASK_DOC=""
# functional testing crashes Ruby from within Portage, but works
diff --git a/dev-ruby/mongoid/mongoid-2.4.4.ebuild b/dev-ruby/mongoid/mongoid-2.4.4.ebuild
deleted file mode 100644
index bd26e9635134..000000000000
--- a/dev-ruby/mongoid/mongoid-2.4.4.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongoid/mongoid-2.4.4.ebuild,v 1.1 2012/02/13 18:37:19 flameeyes Exp $
-
-EAPI=4
-USE_RUBY="ruby18"
-
-#RUBY_FAKEGEM_TASK_DOC=""
-# functional testing crashes Ruby from within Portage, but works
-# outside of it, needs to be investigated thoroughly, but at least
-# unit testing works.
-RUBY_FAKEGEM_TASK_TEST="spec:unit spec:functional"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="${PN}"
-GITHUB_PROJECT="${PN}"
-RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="ODM (Object Document Mapper) Framework for MongoDB"
-HOMEPAGE="http://mongoid.org/"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/v${PV} -> ${GITHUB_PROJECT}-${PV}.tar.gz"
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-ruby_add_rdepend "
- >=dev-ruby/activemodel-3.1
- >=dev-ruby/mongo-1.3
- >=dev-ruby/tzinfo-0.3.22
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/ammeter
- dev-ruby/mocha
- dev-ruby/rdoc
- dev-ruby/rspec
- dev-util/watchr
- )"
-
-DEPEND+=" test? ( dev-db/mongodb )"
-
-all_ruby_prepare() {
- # remove references to bundler, as the gemfile does not add anything
- # we need to care about.
- sed -i -e '/[bB]undler/d' Rakefile || die
- # remove the Gemfile as well or it'll try to load it during testing
- rm Gemfile || die
-}
-
-each_ruby_test() {
- mkdir "${T}/mongodb_$(basename $RUBY)"
- mongod --port 27017 --dbpath "${T}/mongodb_$(basename $RUBY)" \
- --noprealloc --noauth --nohttpinterface --nounixsocket --nojournal \
- --bind_ip 127.255.255.254 &
- mongod_pid=$!
- failed=0
-
- sleep 2
-
- export MONGOID_SPEC_HOST="127.255.255.254"
- export MONGOID_SPEC_PORT="27017"
-
- ${RUBY} -S rake ${RUBY_FAKEGEM_TASK_TEST} || failed=1
- kill "${mongod_pid}"
-
- [[ "${failed}" == "1" ]] && die "tests failed"
-}
diff --git a/dev-ruby/mongoid/mongoid-2.4.5.ebuild b/dev-ruby/mongoid/mongoid-2.4.5.ebuild
deleted file mode 100644
index 5837e9b0ef47..000000000000
--- a/dev-ruby/mongoid/mongoid-2.4.5.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongoid/mongoid-2.4.5.ebuild,v 1.1 2012/02/22 23:56:43 flameeyes Exp $
-
-EAPI=4
-USE_RUBY="ruby18"
-
-#RUBY_FAKEGEM_TASK_DOC=""
-# functional testing crashes Ruby from within Portage, but works
-# outside of it, needs to be investigated thoroughly, but at least
-# unit testing works.
-RUBY_FAKEGEM_TASK_TEST="spec:unit spec:functional"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="${PN}"
-GITHUB_PROJECT="${PN}"
-RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="ODM (Object Document Mapper) Framework for MongoDB"
-HOMEPAGE="http://mongoid.org/"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/v${PV} -> ${GITHUB_PROJECT}-${PV}.tar.gz"
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-ruby_add_rdepend "
- >=dev-ruby/activemodel-3.1
- >=dev-ruby/mongo-1.6
- >=dev-ruby/tzinfo-0.3.22
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/ammeter
- dev-ruby/mocha
- dev-ruby/rdoc
- dev-ruby/rspec
- dev-util/watchr
- )"
-
-DEPEND+=" test? ( dev-db/mongodb )"
-
-all_ruby_prepare() {
- # remove references to bundler, as the gemfile does not add anything
- # we need to care about.
- sed -i -e '/[bB]undler/d' Rakefile || die
- # remove the Gemfile as well or it'll try to load it during testing
- rm Gemfile || die
-
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
-
-each_ruby_test() {
- mkdir "${T}/mongodb_$(basename $RUBY)"
- mongod --port 27017 --dbpath "${T}/mongodb_$(basename $RUBY)" \
- --noprealloc --noauth --nohttpinterface --nounixsocket --nojournal \
- --bind_ip 127.255.255.254 &
- mongod_pid=$!
- failed=0
-
- sleep 2
-
- export MONGOID_SPEC_HOST="127.255.255.254"
- export MONGOID_SPEC_PORT="27017"
-
- ${RUBY} -S rake ${RUBY_FAKEGEM_TASK_TEST} || failed=1
- kill "${mongod_pid}"
-
- [[ "${failed}" == "1" ]] && die "tests failed"
-}
diff --git a/dev-ruby/mongoid/mongoid-2.4.7.ebuild b/dev-ruby/mongoid/mongoid-2.4.7.ebuild
deleted file mode 100644
index 2a76269ee4cf..000000000000
--- a/dev-ruby/mongoid/mongoid-2.4.7.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongoid/mongoid-2.4.7.ebuild,v 1.1 2012/03/22 18:41:07 flameeyes Exp $
-
-EAPI=4
-USE_RUBY="ruby18"
-
-#RUBY_FAKEGEM_TASK_DOC=""
-# functional testing crashes Ruby from within Portage, but works
-# outside of it, needs to be investigated thoroughly, but at least
-# unit testing works.
-RUBY_FAKEGEM_TASK_TEST="spec:unit spec:functional"
-
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="${PN}"
-GITHUB_PROJECT="${PN}"
-RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="ODM (Object Document Mapper) Framework for MongoDB"
-HOMEPAGE="http://mongoid.org/"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/v${PV} -> ${GITHUB_PROJECT}-${PV}.tar.gz"
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-ruby_add_rdepend "
- >=dev-ruby/activemodel-3.1
- >=dev-ruby/mongo-1.6
- >=dev-ruby/tzinfo-0.3.22
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/ammeter
- dev-ruby/mocha
- dev-ruby/rdoc
- dev-ruby/rspec
- dev-util/watchr
- )"
-
-DEPEND+=" test? ( dev-db/mongodb )"
-
-all_ruby_prepare() {
- # remove references to bundler, as the gemfile does not add anything
- # we need to care about.
- sed -i -e '/[bB]undler/d' Rakefile || die
- # remove the Gemfile as well or it'll try to load it during testing
- rm Gemfile || die
-
- #epatch "${FILESDIR}"/${PN}-2.4.5-gentoo.patch
-}
-
-each_ruby_test() {
- mkdir "${T}/mongodb_$(basename $RUBY)"
- mongod --port 27017 --dbpath "${T}/mongodb_$(basename $RUBY)" \
- --noprealloc --noauth --nohttpinterface --nounixsocket --nojournal \
- --bind_ip 127.255.255.254 &
- mongod_pid=$!
- failed=0
-
- sleep 2
-
- export MONGOID_SPEC_HOST="127.255.255.254"
- export MONGOID_SPEC_PORT="27017"
-
- ${RUBY} -S rake ${RUBY_FAKEGEM_TASK_TEST} || failed=1
- kill "${mongod_pid}"
-
- [[ "${failed}" == "1" ]] && die "tests failed"
-}